locked
Outlook prompts for credentials RRS feed

  • Question

  • We have a CCR of 2 Mailbox Server, a 2 node HUB/CAS NLB running Exchange 2007. Since yesterday we are having problem with user complaining about receiving prompts for username and password whenever they start their Outlook client. Users connecting to mail from outside the network using Outlook Anywhere do not face this issue. Kindly provide your suggestion to resolve this issue.

    - Fazal


    Fazal Ur Rehman Shah | Senior Consultant
    Saturday, December 17, 2011 7:23 PM

All replies

  • We have a CCR of 2 Mailbox Server, a 2 node HUB/CAS NLB running Exchange 2007. Since yesterday we are having problem with user complaining about receiving prompts for username and password whenever they start their Outlook client. Users connecting to mail from outside the network using Outlook Anywhere do not face this issue. Kindly provide your suggestion to resolve this issue.

    - Fazal


    Fazal Ur Rehman Shah | Senior Consultant
    • Merged by Sophia Xu Monday, December 19, 2011 6:37 AM duplicate
    Saturday, December 17, 2011 7:22 PM
  • Are your users' machines joined to the domain?  If not, it is normal to get prompted for authentication by Outlook.  If it's happening from inside the network, it could be caused by the InternalURL setting or authentication method.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Saturday, December 17, 2011 9:23 PM
  • I responded to your post in the Admin forum.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Saturday, December 17, 2011 9:23 PM
  • The users machine are joined to the domain. How can I check the InternalURL setting or authentication method ?

     


    Fazal Ur Rehman Shah | Senior Consultant
    Sunday, December 18, 2011 5:37 AM
  • Get-OutlookAnywhere | FL 



    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Sunday, December 18, 2011 6:51 AM
  • IISAuthentiationMethods : <Basic, Ntlm>
    Fazal Ur Rehman Shah | Senior Consultant
    Sunday, December 18, 2011 7:51 AM
  • You may want to verified your exchange servers link connectivity ? Try restarting the ISS service

    Guowen Su
    Cisco Certified Network Associate
    Cisco Certified Internetwork professional - MPLS
    Certified Information Systems Security Professional
    Microsoft Partner Network 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator:Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Certified Ethical Hacker
    Computer Hacking Forensics Investigator
    http://www.microsoft.com/en/sg/default.aspx Our Goal? VERY SATISFIED
    • Proposed as answer by Guowen Su Sunday, December 18, 2011 8:37 AM
    Sunday, December 18, 2011 8:37 AM
  • Have restarted IIS and still the issue was there. Followed a post somewhere in the forum of adding an entry to server in Credential Manager and prompts for credential are not seen any more. I would like to have a permanent solution with little intervention from user's side. 

    After sometimes now the issue has resurface, seems like adding credentials in Credential Manager is not working. After starting Outlook, it asks for username and password after sometimes. Please help.


    Fazal Ur Rehman Shah | Senior Consultant
    Sunday, December 18, 2011 9:31 AM
  • Hi
      If it is convenient , you can turn off NLB and open outlook again.  Maybe it is NLB setting problem.

    Terence Yu

    TechNet Community Support

    Monday, December 19, 2011 2:12 AM
  • It was working fine and the issue appeared after I made certain changes as per http://support.microsoft.com/kb/940726 because we were facing issue with Security Alert when starting Outlook clients.
    Fazal Ur Rehman Shah | Senior Consultant
    Monday, December 19, 2011 11:09 AM
  • Hi Fazal,

    That link describes the process for changing URL values in relation to the CAS certificate. If you followed that process and now have a situation where the client is repeatedly asked for credentials I suggest that your internalurl value is not listed as a common name on your exchange certificate. If your internalurl value is "server.domain.com...." then "server.domain.com" needs to be listed on your exchange certificate.

    You can get the internalurl by...

    Get-ClientAccessServer casserver1 | fl *InternalUri*

    Kind Regards


    • Edited by AllBarOne Tuesday, December 20, 2011 7:54 AM
    Monday, December 19, 2011 11:52 AM