WSS 3.0 Calculated Columns (Always Errors, even simple example calculations) RRS feed

  • Question




    I have some problems with calculated columns in a basic WSS 3.0 standard list (no MOSS server)


    When i create a new calculated column, with formula:


    =LEFT([Title]) ==> it gives me the first char of the title (correct according http://office.microsoft.com/en-us/sharepointtechnology/HA011610151033.aspx )


    ps: when viewing properties of calculated column =:=> formula is changed to =LEFT(Title) without the brackets but seems to work.


    Now, when I take the following formula:

    =LEFT([Title],2)  ==> I get the "The formula contains a syntax error or is not supported. " (and yes, all my titles are even longer than 2 chars)


    When i do some more test, none of thh functions work which have some extra parameter. (UPPER(...) works, but MID(...,..,..) not)

    Even basis examples (http://office.microsoft.com/en-us/sharepointtechnology/HA011610271033.aspx) with formula

    =MID("Fluid Flow",1,5)

    gives always the "The formula contains a syntax error or is not supported. "



    ==> As now, I can't use much of calculated columns (ultimate goal was calculating a date/time column, based on a input-text-column) ==> didn't work either.


    Are the calculations not supported somehow on simple basic WSS 3.0 (with SQL 2005 server on different server)


    Thx for any comments or suggestions



    • Edited by Mike Walsh FIN Tuesday, January 5, 2010 3:45 PM ... removed from end of Title
    Thursday, June 14, 2007 10:10 AM


All replies

  • Hello,

    I just had the same problem - When I use ";" instead of "," it works fine.

    Hope that helps,


    Monday, June 18, 2007 9:00 AM



    At first tests, it seems to work with the semicolumn ";"

    ==> very strange it works that way (and it is undocumented), even more surprising is, how do you find such a solution.


    But thank you veru much, it is working.






    Monday, June 18, 2007 9:53 AM
  •  Delaware wrote:


    I just had the same problem - When I use ";" instead of "," it works fine.

    Hope that helps,


    Hi Rainer,


    I just spent 2 hours trying to make some functions to work in calculated column in list in MOSS 2007. After I tried with several trivial examples without any success I tried searching on net and found your post.

    I just wanted to thank you for posting the solution.




    Tuesday, March 11, 2008 9:09 AM



    I had the same problem - When I use ";" it works perfectly.




    Tuesday, April 8, 2008 12:19 PM
  • extraordinary helpfull,,thanks for sharing about ";" BUG.


    Tuesday, April 8, 2008 2:21 PM
  • Thanks too , merci beaucoup !!!!



    Monday, May 5, 2008 2:56 PM
  • Moving the thread to Admin as it's not a customization (SPD 2007) issue but an Admin one.
    Tuesday, May 6, 2008 6:07 AM
  • thanks. it works for me.
    www.aristonsoft.com - .net 3.5 hosting provider in India
    Tuesday, March 31, 2009 1:17 PM
  • I'd just like to throw into the thread a probable reason for ; working and , not.

    There is a very old typical problem in macro forumula (i.e. going back to Lotus 1-2-3) where people using a computer that is not set to US English have problems with their forumulas. It's then a question of finding which "similar" character(s) work in the formulas.

    In the old days I remember replacing , with .  but I also remember cases where I to find some other character.

    The problem is that the Microsoft examples (what else is new!) always assume that people are based in the US and using US keyboards and US settings.

    (I've finally - after all this time, upped this answer from Propose to full Answer status. It is howeve an answer to this specific question only.
    WSS FAQ sites: WSS 2.0: http://wssv2faq.mindsharp.com WSS 3.0 and MOSS 2007: http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 and MOSS 2007 Books (including foreign language titles) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Tuesday, March 31, 2009 1:46 PM
  • I'm having this problem... only replacing "," with ";" doesn't seem to fix it.

    I'm trying to use the formula =IF([OSInstalled],0.75,0) but I keep receiving "The formula contains a syntax error or is not supported. "

    I've got 2 farms, in 1 of them this works in the other it doesn't. The only difference between them is that one is x86 and the other is x64.

    I've tried the suggested solution but for some reason it doesn't solve the problem.

    Wednesday, April 29, 2009 11:46 AM
  • I found the solution...

    In fact it's not only the separator character that changes, the floating point changes as well, so I should change the "." for a ","

    The correct expression should be:


    Wednesday, April 29, 2009 2:30 PM
  • Thanks for the tip, it worked for me!

    I like to add that I had this problem when working with SharePoint variations!

    In the English variation the formula looked like this:

    but in the Danish variation it had to look like this:

    So just changing from variation (language) to another caused the problem.


    Tuesday, January 5, 2010 3:38 PM
  • Hi All,

    I Tried ; instead of , but it didnt worked for me.

    Can any one tell me how many AND statements we can use in OR() statement for IF condition.

    Thanks in Advance..
    Thursday, May 12, 2011 6:10 AM
  • check this calculated columns formulas referrence


    Rami M. Nassar
    My Blog
    Don't forget to click Mark as Answer on the post that helped you.
    Sunday, November 13, 2011 9:37 AM