locked
Receive Connector - Accept-Any-Sender RRS feed

  • Question

  • I am confused by a receive connector that is configured to Send-As Any Sender... But will not send because "Client does not have permissions to send as this sender".

    What am I missing?

    +++++++++++++++

    AUTH LOGIN,
    334 <authentication response>,
    334 <authentication response>,
    SMTPSubmit SMTPAcceptAnyRecipient SMTPAcceptAnySender BypassAntiSpam AcceptRoutingHeaders,Set Session Permissions
    MYDOMAIN\user,authenticated
    235 2.7.0 Authentication successful,
    MAIL FROM: <User@mydomain.org>,
    08CD274B21E193C1;2010-10-25T16:41:39.591Z;1,receiving message
    550 5.7.1 Client does not have permissions to send as this sender,
    QUIT,

    +++++++++++++++++

    KFletcher

    Monday, October 25, 2010 5:21 PM

Answers

  • New-ReceiveConnector -Name "Anonymous Relay" -Usage Custom -PermissionGroups AnonymousUsers -Bindings 10.2.3.4:25 -RemoteIpRanges 192.168.5.77

    Get-ReceiveConnector "Anonymous Relay" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"


    Dhafer HAMMAMI
    Thursday, October 28, 2010 10:41 AM
  • Hi,

    1. Right click the receive connector your created and choose properties.

    2. In Network tab, Make sure that the IP address of the SMTP server is in the remote IP range.

    3. In Authentication tab, only select the option "Externally Secured".

    4. In permission gourp tab, select all items.

    5. Restart transport service.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    • Marked as answer by Gen Lin Friday, November 5, 2010 6:04 AM
    Monday, November 1, 2010 4:53 AM

All replies

  • New-ReceiveConnector -Name "Anonymous Relay" -Usage Custom -PermissionGroups AnonymousUsers -Bindings 10.2.3.4:25 -RemoteIpRanges 192.168.5.77

    Get-ReceiveConnector "Anonymous Relay" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"


    Dhafer HAMMAMI
    Thursday, October 28, 2010 10:41 AM
  • Hi,

    1. Right click the receive connector your created and choose properties.

    2. In Network tab, Make sure that the IP address of the SMTP server is in the remote IP range.

    3. In Authentication tab, only select the option "Externally Secured".

    4. In permission gourp tab, select all items.

    5. Restart transport service.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    • Marked as answer by Gen Lin Friday, November 5, 2010 6:04 AM
    Monday, November 1, 2010 4:53 AM