none
Problems Streaming with new server (0A-20000194 and 41520) RRS feed

  • Question

  •  


    Hello. We currently run a Softgrid 4.2.2 server.

    We are mgirating to Windows 7, and have setup a new APP-V server. The Windows 7 build points to the new App-V server; all the apps loaded into the new app-v server console are listed correctly and have the expected icons and file associations on the client.

    However when I try and launch an app, I get the following client error:

    The Application Virtualization Client could not launch Mozilla Firefox 4 4.0.

    The package requested could not be found in the system data store or the files associated with this package could not be found on the server. Report the following error code to your System Administrator.

    Error code: 4615186-1690140A-20000194

    The server reports:

    [2011-05-18 14:58:24.402] XXX 2336 2452 SW_CacheHandle::SW_CacheHandle - "Default Provider" guest781 firef4_01/MOZILLA_FIREFOX_4_MNT_2.sft 4 41520 "Package file not found: \\server\share\appv\firef4_01/MOZILLA_FIREFOX_4_MNT_2.sft.

    The default content path under System Options is correctly set to the new app-v app area (\\server\share\appv). However I did notice that the registry key SOFTGRID_CONTENT_DIR had defaulted to something else (D:\program files(x86)\ etc.). I have edited the registry and used the same path as what is listed under the default content share and rebooted the server however I still get the same error.

    The "\\server\share\appv" server path (a DFS share which maps to \\appv_server\content on the app-v server) above matches the default content share location.

    I can browse to the the default content share (\\isad.isadroot.ex.ac.uk\uoe\appv\) on a client PC and access the OSD files etc., but I cannot stream them.

    The OSD is configured:

    RTSP://appv_server:554/firef4_01/MOZILLA_FIREFOX_4_MNT_2.sft

    ...and the folder firef4_01 exists on the default content share of:

    \\server\share\appv

    ...in fact you can browse straight to:

    \\server\share\appv\firef4_01\MOZILLA_FIREFOX_4_MNT_2.sft

    Any ideas?
    Wednesday, May 18, 2011 5:26 PM

Answers

  • It might be worth adding the computer account to the permissions list as well, just to confirm that the request is occuring via the computer account or the service account.



    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    • Marked as answer by Rashmika Thursday, May 19, 2011 11:40 AM
    Thursday, May 19, 2011 11:30 AM
    Moderator

All replies

  • Hello,

     Have you tried altering the / to \. This can be done under packages node on the App-V Mgt server.

    Considering that the log says this;

    "Package file not found: \\server\share\appv\firef4_01/MOZILLA_FIREFOX_4_MNT_2.sft


    /Znack
    Wednesday, May 18, 2011 5:46 PM
  • Does the server itself have rights to the Content share?

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Wednesday, May 18, 2011 5:56 PM
    Moderator
  • Does the server itself have rights to the Content share?


    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    The APP-V service account, System and local Administrators have full control of the share and full control NTFS permissions on the folder.

     

    Hello,

     Have you tried altering the / to \. This can be done under packages node on the App-V Mgt server.

    Considering that the log says this;

    "Package file not found: \\server\share\appv\firef4_01/MOZILLA_FIREFOX_4_MNT_2.sft


    /Znack

    My apologies. i should have mentioend that I have already tried amending the slash on the package. Even when set to a black slash:

     

    [2011-05-19 10:22:53.312] XXX 2152 1512 SW_CacheHandle::SW_CacheHandle - "Default Provider" guest781 inksc_01/GNU_INKSCAPE_MNT_2.sft 4 41520 "Package file not found: \\server\share\appv\inksc_01\GNU_INKSCAPE_MNT_2.sft.

     

    I can browse to the SFT file from a client when using a forward slash too.
    Thursday, May 19, 2011 10:26 AM
  • It might be worth adding the computer account to the permissions list as well, just to confirm that the request is occuring via the computer account or the service account.



    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    • Marked as answer by Rashmika Thursday, May 19, 2011 11:40 AM
    Thursday, May 19, 2011 11:30 AM
    Moderator
  • You Sir are a star.

     

    The APPV service is running under the Network Service account. I amended the permissions on the share and folder to include teh Network Service account and the apps are now streaming.

     

    *sigh of relief*

     

    ...in my defense I didn't build the server :-P

    Thursday, May 19, 2011 11:40 AM
  • Thanks man!! Indeed it was a permissions problem. Thanks from Ecuador South America.
    Wednesday, December 14, 2011 4:56 PM
  • Also worked for me.

    Thankz

    Thursday, April 12, 2012 9:41 AM
  • Hello,

    I have a production environment Windows 2008 R2 64bit with appv 4.6.After adding a new package i recieve the following error: 4604EE8-19D02E0A-10000002<o:p></o:p>

    if have build a test environment with Windows 2003 and a Windows 2008 server. Same Appv version as my production environment. <o:p></o:p>

    The application that i build for the production i have imported in my test environment on my Windows 2003 environment it streams and on my Windows 2008 server i receive the same error. <o:p></o:p>

    Looking in the logfile off Appv gives me the following information:<o:p></o:p>

    The Application virtualization client could not connect to stream URL: rtsp://%sft_softgridserver%:554/app/app.sft (rc 19d02e0a-10000002, original rc 19d02e0a-10000002) <o:p></o:p>

    The firewall on this server is off but I can’t telnet to the appv serverr. From the Windows 2003 I can telnet to the appv server. <o:p></o:p>

    The network service account has full control on share and file permissions. What can I check further to resolve the issue? <o:p></o:p>

    Thanks in advance


    Wednesday, October 9, 2013 1:59 PM
  • Hello,

    I suggest you create your own thread, as this is considered resolved.

    Have you looked into what the environment variable SFT_SOFTGRIDSERVER should be?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, October 9, 2013 4:20 PM
  • It worked for me! I never thought this could be the issue. Many thanks! :)
    Friday, December 19, 2014 12:11 PM
  • I am glad this is still helping people!
    Monday, December 22, 2014 11:19 AM