none
An unexpected error has occurred 0xc0000017 RRS feed

  • Question

  • We are running MDT 8.1 and we are using WDS to deploy our images.  After DHCP takes over the boot manager loads then we select what boot image we want to run the system loads the files. Then we get the message “An unexpected error has occurred 0xc0000017” What does this mean and how can we get it to work?  Is there a log file I can check for failed deployments?  I also have been able to deploy the same image using the same setup to get two machines working.  These machine are all the same the ones that worked and the ones that have failed.

    Friday, December 20, 2013 8:58 PM

All replies

  • Using the err.exe command shows:

    C:\>err 0xc0000017
    # for hex 0xc0000017 / decimal -1073741801 :
      STATUS_NO_MEMORY                                              ntstatus.h
    # {Not Enough Quota}
    # Not enough virtual memory or paging file quota is available
    # to complete the specified operation.
    # 1 matches found for "0xc0000017"

    Are you running this on machines with less than 1GB of memory? or other weird machines (and when I mean weird, I mean that the machine should be from one of the top 10 OEM vendors, and be a client machine ).

    Keith Garner - keithga.wordpress.com

    Monday, December 30, 2013 4:30 AM
    Moderator
  • Key Keith sorry for getting back to you so late.  Our deployment system is a i3 Dell Laptop with 3.80GB of RAM and a 150GB HDD.  And the systems we are deploying to are all the same systems, Dell Desktops with 4 GB of RAM and a 150GB HDD.  Could it be the image that we are pushing out?  Because we hooked up an older deployment laptop Core 2 Duo, 4GB of RAM, 1 TB HDD.  And it seems to be working fine.  What do you think?
    Thursday, January 2, 2014 3:17 PM
  • Ok so this time I am trying to capture a image so I run cscript \\ets-deploy\deployment\litetouch.vbs and the system runs what it needs to then it reboots and I get the same error message "Ramdisk device creation failed due to insufficient memory".  And the system we are trying to capture has 2 GB of RAM and the deployment system has 4 GB of RAM.  This error message happens on every machine we try to capture or deploy too.  What do you think the problem could be?
    Monday, January 6, 2014 3:30 PM
  • Monday, January 6, 2014 7:20 PM
    Moderator
  • Ok we will try it, but let me ask you this what system do we put this hotfix on?  Our deployment system or the system we are deploying to?
    Thursday, January 9, 2014 2:50 PM
  • I have seen this issue before (specifically with W8 and MDT 2013, MDT2012 worked fine) and it had to do with the drivers that were being injected into the WinPE boot image. I would perform a driver cleanup and use only WinPE drivers necessary for your deployment needs. 

    List of WinPE drivers:
    [-] DellTechCenter.com
    [-] WinPE 4.0 & WinPE 5.0


    _JoeG
    Dell - Systems Integration Consultant
    Twitter: @8bits1byte 

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, January 10, 2014 12:03 AM