none
Windows 10 Kiosk mode - cannot run towards localhost? RRS feed

  • Question

  • Hi everyone,

    We are trying to setup a Windows 10 kiosk (via Intune), everything works fine except one thing...
    Kiosk Browser app cannot run towards http:/localhost

    (There is no problem to run http:/localhost from MS Edge, IE, och towards IP of the kiosk device from another device from the same kiosk app).

    But not to itsself. Kiosk Browser runs without problem any extern URL, but not http://localhost, http://127.0.0.1 or similar.

    "Workarounds" like a fake hostname.

    It does not work towards own local in the network.

    Is there any way to allow Kiosk browser to comunicate with the localhost:80?

    Monday, January 28, 2019 6:09 PM

Answers

  • Maybe it can be usefull for someone, fixed with 

    CheckNetIsolation LoopbackExempt -a -n="microsoft.kioskbrowser_8wekyb3d8bbwe"

    • Marked as answer by Eduard Frokh Thursday, January 31, 2019 10:36 AM
    Tuesday, January 29, 2019 2:11 PM

All replies

  • Hi,

    Thanks for posting in Microsoft TechNet Forum.

    According to your description, it is recommended that you try the following methods:

    1. Try unistall and reinstall.

    2. Check the update and then see if it works.

    Meanwhile, please refer to the following link which may help:

    https://github.com/angular/angular-phonecat/issues/322

    Note: This is a third-party link and we do not have any guarantees on this website. This is just for your convenience. And Microsoft does not make any guarantees about the content.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Monday, January 28, 2019 7:38 PM
  • Hi,

    Thank you for answers.

    1. Same problem exists on several devices, it does not look like uninstall/install can help

    2. We use the latest version from MS store: https://www.microsoft.com/en-us/p/kiosk-browser/9ngb5s5xg2kp?activetab=pivot:overviewtab

    We would like to avoid third-party software like Chrome and so on, and because Microsoft reccomends just Kiosk Browser together with Intune for our solution it would be probably best. But the only problem is that it does not want to open connection to the devices itself.


    Tuesday, January 29, 2019 8:40 AM
  • Maybe it can be usefull for someone, fixed with 

    CheckNetIsolation LoopbackExempt -a -n="microsoft.kioskbrowser_8wekyb3d8bbwe"

    • Marked as answer by Eduard Frokh Thursday, January 31, 2019 10:36 AM
    Tuesday, January 29, 2019 2:11 PM
  • Hi,

    Thank you for your feedback.

    Please mark it as an answer so that people in need of help in the future can refer to it.

    Thank you for your cooperation.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, January 29, 2019 2:43 PM
  • Hi Eduard,

    I'm glad you found a fix. I have this same restriction ruining my day. But I don't know where you applied the LoopbackExempt setting. I see it is a PowerShell command but I don't understand how that helps Intune settings. Can anyone help flesh out this answer?

    Thank you,

    Chris


    Tuesday, March 10, 2020 2:38 AM