none
"Archive not found" due to corrupted gpostate.xml file RRS feed

  • Question

  • Last week, our host failed and took a bunch of our VMs offline unexpectedly. Our AGPM server was among the unfortunate. Ever since the failure, our AGPM console fails to load the archive when you open GPM and click on "Change Control". Instead, it throws the following error: 

    Failed to read the permissions for this archive.

    The following error occurred:
    Root element is missing.
    System.Xml.XmlException (80131940)

    After clicking "Ok" through this error, you are presented with "Archive not found" under every tab in Change Control. 

    I theorized that this might be due to a problem with the gpostate.xml file so I opened that file to see if anything looked out of place. Unfortunately, the entire file was blanks. Not blank, but literally hundreds of lines of blanks. 

    Next, I tried renaming the bad xml file and then opened GPM again to see if it would rebuild the file properly. It DID create a new gpostate.xml file, however it was a fresh file as if I just installed AGPM. This caused Change Control to act as if I had never controlled any of my policies. At this point, it appeared that my entire history of changes was lost and I'd have to re-control everything and start over. Not ideal, so I moved on.

    The last thing I tried is I replaced the gpostate.xml file with a backup from the last time we had AGPM issues in December. After opening up AGPM, it fully reverted to that version. Unfortunately, that version was missing all but 3 of the controlled policies as well so it wasn't much better than starting from scratch. 

    At this point we aren't sure how to rebuild the gpostate.xml file so that everything is up to date and accurate. The fact that this single file controls so much in the interface tells me that surely there is a mechanism to rebuild or restore it and I just don't know what that is.

    Does anybody know how to restore this file?  

    Tuesday, March 24, 2015 5:39 PM

All replies