none
Set up workgroup server as time server and client setup RRS feed

  • General discussion

  • I have 6 computers in a workgroup that need to be synchronized to a workgroup server.  The server is a virtual Win 7 running on a Windows 10 host.  Neither the server or client computers have internet access.  I started the process by configuring the host to use its CMOS clock as its time source, which seems to have worked. The client computers are not virtual and can communicate with the Win 10 host as I am able to RDP to the host from the clients.  I made the following registry key changes to get that accomplished.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\Config]
    "AnnounceFlags"=dword:00000005

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\Parameters]
    "Type"="NoSync"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\TimeProviders\NtpClient]
    "Enabled"=dword:00000000

    "SpecialPollTimeRemaining"=hex(7):00,00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\TimeProviders\NtpServer]
    "Enabled"=dword:00000001

    <-------End of REG file------->

    After applying these changes, I ran the following 'w32tm /config /update /syncfromflags: NO 

    I get a message that the command is successful.

    These changes are based on the following post:

    https://social.technet.microsoft.com/Forums/office/en-US/04865e36-d43d-4167-a07d-9f28fd4f22fa/how-do-you-configure-windows-time-synchronization-in-a-workgroup-with-no-servers?forum=winserverDS

    However, when I do a net time,  I get a message that no time data is found. 

     Next, I attempted to configure one of the clients to use the Win 10 host as the reliable time source using the following command, based on microsoft kb 875424

    • w32tm /config /manualpeerlist:TimeServerFQDNorIPAddress,0x8 /syncfromflags:MANUAL /reliable:yes
    • w32tm /config /update
    • net stop w32time
    • net start w32time
    • w32tm /resync

    I get a message that all commands are successful.  However, when I do the resync, I get a message that no time server is found.  the command is successful.  However, when I run 'net time', I get a message stating 'no time data is available.'

    Thursday, April 4, 2019 12:27 PM

All replies

  • I have 6 computers in a workgroup that need to be synchronized to a workgroup server.  The server is a virtual Win 7 running on a Windows 10 host.  Neither the server or client computers have internet access.  I started the process by configuring the host to use its CMOS clock as its time source, which seems to have worked. The client computers are not virtual and can communicate with the Win 10 host as I am able to RDP to the host from the clients.  I made the following registry key changes to get that accomplished.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\Config]
    "AnnounceFlags"=dword:00000005

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\Parameters]
    "Type"="NoSync"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\TimeProviders\NtpClient]
    "Enabled"=dword:00000000

    "SpecialPollTimeRemaining"=hex(7):00,00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\TimeProviders\NtpServer]
    "Enabled"=dword:00000001

    <-------End of REG file------->

    After applying these changes, I ran the following 'w32tm /config /update /syncfromflags: NO 

    I get a message that the command is successful.

    These changes are based on the following post:

    https://social.technet.microsoft.com/Forums/office/en-US/04865e36-d43d-4167-a07d-9f28fd4f22fa/how-do-you-configure-windows-time-synchronization-in-a-workgroup-with-no-servers?forum=winserverDS

    However, when I do a net time,  I get a message that no time data is found. 

     Next, I attempted to configure one of the clients to use the Win 10 host as the reliable time source using the following command, based on microsoft kb 875424

    • w32tm /config /manualpeerlist:TimeServerFQDNorIPAddress,0x8 /syncfromflags:MANUAL /reliable:yes
    • w32tm /config /update
    • net stop w32time
    • net start w32time
    • w32tm /resync

    I get a message that all commands are successful.  However, when I do the resync, I get a message that no time server is found.  the command is successful.  However, when I run 'net time', I get a message stating 'no time data is available.'

    Correction to the command I ran on the server:  'w32tm /config /update /syncfromflags: NO /reliable: YES

    Next, I ran 'w32tm /query /status' and get the following:

    Leap Indicator: 0(no warning)
    Stratum: unspecified
    Precision: -6 (15.625ms per tick)
    Root Delay: 0.0000000s
    Root Dispersion: 10.0000000s
    ReferenceId: 0x4C4F434C (source name:  "LOCL")
    Last Successful Sync Time: unknown
    Source: Local CMOS Clock
    Poll Interval: 10 (1024s)


    Thursday, April 4, 2019 12:51 PM
  • I need to know the correct commands to issue on the server host and on the clients.  Also, will the virtual server need to be configured the same as the clients?
    Thursday, April 4, 2019 1:15 PM