locked
Send Connectors RRS feed

  • Question

  • Current Setup;

    Edgesync connectors in place and fully operational - sending email

    scope is ALL mail send to EDGE Server cost = 100

    Also have a connector that is meant to send mail to an alternative connector, but EDGE connector always wins

    this connector is setup as

    scope is contoso.com sent to RELAY server cost = 50

    Any ideas? Or will EDGE connector always win regardless of COST ?

    thank you.


    Friday, July 1, 2016 1:03 AM

All replies

  • Hi,

    In general,cost is used to set the priority of this connector, used when two or more connectors are configured for the same address space. The lower the cost higher the priority.

    We use the Source Server tab to specify the mailbox servers that can use this Send connector. Please use the below command to check the source server :

    Get-SendConnector "Send Connector" | FL 

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    David Wang_
    TechNet Community Support

    Monday, July 4, 2016 9:09 AM
  • Here is the output of the two connectors

    The EDGE connector always wins, and mail flows this way, regardless....

    AddressSpaces                : {smtp:*;100}
    AuthenticationCredential     :
    CloudServicesMailEnabled     : False
    Comment                      :
    ConnectedDomains             : {}
    ConnectionInactivityTimeOut  : 00:10:00
    ConnectorType                : Default
    DNSRoutingEnabled            : False
    DomainSecureEnabled          : False
    Enabled                      : True
    ErrorPolicies                : Default
    ForceHELO                    : False
    Fqdn                         :
    FrontendProxyEnabled         : False
    HomeMTA                      : Microsoft MTA
    HomeMtaServerId              : EDGESERVER01
    Identity                     : EdgeSync - ADSITE1
    IgnoreSTARTTLS               : False
    IsScopedConnector            : False
    IsSmtpConnector              : True
    MaxMessageSize               : 35 MB (36,700,160 bytes)
    Name                         : EdgeSync - ADSITE1
    Port                         : 25
    ProtocolLoggingLevel         : None
    RequireOorg                  : False
    RequireTLS                   : False
    SmartHostAuthMechanism       : None
    SmartHosts                   : {mail.emailrelay.com}
    SmartHostsString             : mail.emailrelay.com
    SmtpMaxMessagesPerConnection : 20
    SourceIPAddress              : 0.0.0.0
    SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
    SourceTransportServers       : {EDGESERVER01}
    TlsAuthLevel                 :
    TlsCertificateName           :
    TlsDomain                    :
    UseExternalDNSServersEnabled : False




    AddressSpaces                : {SMTP:contoso.com;10}
    AuthenticationCredential     :
    CloudServicesMailEnabled     : False
    Comment                      :
    ConnectedDomains             : {}
    ConnectionInactivityTimeOut  : 00:10:00
    ConnectorType                : Default
    DNSRoutingEnabled            : False
    DomainSecureEnabled          : False
    Enabled                      : True
    ErrorPolicies                : Default
    ForceHELO                    : False
    Fqdn                         :
    FrontendProxyEnabled         : False
    HomeMTA                      : Microsoft MTA
    HomeMtaServerId              : MAILBOXSERVER01
    Identity                     : MailConnector
    IgnoreSTARTTLS               : False
    IsScopedConnector            : False
    IsSmtpConnector              : True
    MaxMessageSize               : 35 MB (36,700,160 bytes)
    Name                         : MailConnector
    Port                         : 25
    ProtocolLoggingLevel         : None
    RequireOorg                  : False
    RequireTLS                   : False
    SmartHostAuthMechanism       : None
    SmartHosts                   : {mail.emailrelay.com}
    SmartHostsString             : mail.emailrelay.com
    SmtpMaxMessagesPerConnection : 20
    SourceIPAddress              : 0.0.0.0
    SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
    SourceTransportServers       : {MAILBOXSERVER01}
    TlsAuthLevel                 :
    TlsCertificateName           :
    TlsDomain                    :
    UseExternalDNSServersEnabled : False

    Tuesday, July 5, 2016 12:12 AM
  • Hi,

    I suggest we try to create a new send connector with the same AddressSpaces,then check if the same thing occurs.

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    David Wang_
    TechNet Community Support

    Wednesday, July 6, 2016 1:42 AM
  • Hi,

    I suggest we try to create a new send connector with the same AddressSpaces,then check if the same thing occurs.

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    David Wang_
    TechNet Community Support

    Connectors recreated.

    Email wont send, its preference is always to go via the EDGE connector ?

    Sunday, July 24, 2016 10:32 PM