none
Logon Script with PowerShell

    Question

  • Hi

    I’m having some problems running PowerShell scripts using the Logon GPO, as in it does not run at all.

    I have Disabled the Configure Logon Script Delay, from the description it should then run scripts without delay.

    I have also Enabled Turn on Script Execution (Allow all Scripts), from the description it should do about the same as Set-ExecutionPolicy -ExecutionPolicy Unrestricted -Force that I have also tried to start my script with, but it just does not run from the GPO.

    I can copy the script to the computer and run it manually.

    EDIT: Looks like it is working on Windows 7 but not Windows 8 !

     

    /Lars


    • Edited by latofi Tuesday, March 31, 2015 12:40 PM
    Tuesday, March 31, 2015 12:12 PM

Answers

  • Hi,

    >>Looks like it is working on Windows 7 but not Windows 8 !

    On Windows 8 clients, we can run command gpresult/h gpreport.html to collect group policy result report to check how group policy settings are being applied. Besides, on Windows 8 clients, we can try to run the script from the shared location where it is stored to see if it can be run successfully. Moreover, we can check event logs in Event Viewer to see if some related events were logged.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, April 01, 2015 2:17 AM
    Moderator