locked
Outlook "autocomplete" now replaced by five "Recent People" RRS feed

  • Question

  • How come I can't see the usual list with autocomplete and instead it is replaced with my 5 most recent people. Very annoying as I need to see the autocomplete list rather than recent people. My autocomplete is turned on an all settings appear like they should. Anyone have suggestions?
    Thursday, November 16, 2017 7:41 PM

All replies

  • This is happening on some of our machines, too. Very frustrating for us and for the clients who are calling us looking for answers. Different machines, same Office 365 subscription, same build/version Outlook, yet some have the Recent People and some show autocomplete entries based on the address book. I can't figure out what's difference. Same plugins enabled, same contact list, same email account, different computer and Outlook profile. 
    Thursday, November 16, 2017 8:34 PM
  • Hi both,

    Based on my test in several versions of Outlook, it seems to me the "Recent people" might be a change in Version 1710. I did much research, but currently found few documentation stating this. For now, I'll help submit this via our internal way.

    It is also encouraged to submit your feedback via Outlook UserVoice forum. Microsoft loves hearing all customers' suggestions and is committed to improving users' experience on the products. Thanks for your understanding and support.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, November 20, 2017 8:02 AM
  • Just came across this as well. However, after some testing, it appears that the Recent People still uses the same Autostream.dat file, so they simply need to type in more of the recipients name/email address. In other words, simply typing in "S" will just show the most recent recipients with S in their name/email, but typing in "Steph" will pull up the most recent 5 with Steph in their contact info.

    Still shortsighted and an entirely unnecessary modification, but the only true difference is that it only shows 5 people sorted by most recent, when there may be more than five stephanies or stephens. Typing in more should work for your clients until microsoft decides to go back to the "Ain't Broke, don't fix" strategy.

    Monday, November 20, 2017 7:15 PM
  • This change to only showing five recent entries is a BIG problem for some of the customers that I support. Comment at the following page to have it restored to the larger selection of autocomplete options.

    https://outlook.uservoice.com/forums/322590-outlook-2016-for-windows/suggestions/34244221-auto-complete-using-full-contact-list-instead-of-j

    Tuesday, May 29, 2018 5:18 PM
  • Hi,

    You can try with the following registry key as workaround

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Options​
    DisableAutoCompleteUpdate=dword:1

    • Proposed as answer by autotalon Wednesday, May 30, 2018 8:53 PM
    Tuesday, May 29, 2018 7:54 PM
  • Thanks for the quick response! I'll try it on a customer's computer.
    Wednesday, May 30, 2018 1:25 PM
  • Hi,

    You can try with the following registry key as workaround

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Options​
    DisableAutoCompleteUpdate=dword:1

    Works perfectly, thanks!

    A+ Certified IT Technician

    Wednesday, May 30, 2018 8:53 PM
  • I created that registry key and it worked! Thanks a bunch!


    • Edited by Skriddles Friday, June 8, 2018 2:47 PM
    Friday, June 8, 2018 2:06 PM
  • Wow, it worked.

    For the less tech proficient (like me).

    Start Menu -- type in RegEdit

    In RegEdit navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Options

    Right click on the window on the right in RegEdit.

    Select New to create a new key

    Choose DWORD

    Change the name of the new key to "DisableAutoCompleteUpdate"

    Right click on the changed name and choose "Modify"

    Type 1 in the box.

    Press OK

    If Outlook is open, close and reopen.

    Should work.



    Monday, June 18, 2018 8:42 PM
  • My "recent people" is broken and shows the wrong name (but the correct email address) For example I have, say, John Smith and Mary Smith, both completely separate contacts. When I start typing John Smith's email address the recent people entry shows Mary Smith with John's email address!  This is happening with a few contacts that have some similarity in their Outlook Contact cards.

    I even tried deleting the 'Mary Smith' entire contact card. This fixed the recent people entry when creating an e-mail, but when I tried to recreate Mary Smith's contact card, as soon as I tried to enter her e-mail address the recent people popped up WITH her e-mail address, and when I selected it and moved to the next field it removed the address from the email address field! So now I CANNOT enter an email address on her contact card!

    Great job, Microsoft! What the hell have you done now?

    Tuesday, July 17, 2018 3:23 PM
  • I also just tried this solution and it worked perfectly!
    Tuesday, July 24, 2018 11:21 PM
  • Mattu00 - This is simply not true.   I typed most of their names and still listing only 5. It looks like Outlook Calendar is set to just show 5 recipients. 

    Is there a way to show ALL?


    • Edited by JulieRock Monday, February 4, 2019 6:17 PM
    Monday, February 4, 2019 6:16 PM
  • THANK YOU, autotalon!!  Saved me TONS of headache and very much appreciated.
    Thursday, February 7, 2019 3:51 PM
  • This whole thing is fucking nuts.....there are actually people out there that think that this would work as in "recent" for 5 people????  Just lost thousands of dollars and the person who thought of this numskull idea better be fired NOW
    Sunday, June 16, 2019 7:09 PM
  • This worked for me and thanks for the non-techie explanation....

    Thursday, February 6, 2020 9:51 AM