Cannot set default wallpaper on 1st logon if user does not have rights to change wallpaper RRS feed

  • Question

  • When certain users log on to Windows 7 machines, they are presented with a black desktop background, even through we do not set the wallpaper via group policy.

    I belive the issue is group policy related through, because all the users experiancing this are in the same OU.  Here are the Desktop related Policies that I have configured:

    Prohibit Adding Items: Enabled
    Prohibit changes: Enabled
    Prohibit deleting items: Enabled
    Prohibit editing items: Enabled

    Control Panel/Personalization
    Prevent changing color scheme: Enabled
    Prevent Changing Desktop Backgroup: Enabled
    Prevent Changing Desktop Icons: Enabled
    Prevent Changing Screen Saver: Enabled
    Prevent Changing Theme: Enabled
    Prevent Changing Window Color and Appearance: Enabled

    What I would like is the default Windows 7 theme to show up, the same way it does for users not in a paticular OU, but I do want to enforce the above settings as well.  Any idea of one of the above settings could prevent the default background/theme from loading?

     *Edited title to reflect new info*

    • Edited by MMB-LPS Tuesday, May 18, 2010 3:51 PM
    Tuesday, May 18, 2010 1:41 PM


  • OK, I did testing with each of the GP Settings and this one is the culprit:

    Prevent Changing Desktop Background

    It seems like when creating the profile, the system cannot set the walpaper for the default theme (TranscodedWallpaper) unless the user is allowed to change wallpapers. 

    I can try to force a wallpaper on workstations via a group policy preferences setting, but this sounds like a bug to me.  Creating the profile with the default settings should not require explicit user rights, no?

    • Marked as answer by Arthur Xie Wednesday, May 19, 2010 6:36 AM
    Tuesday, May 18, 2010 3:48 PM