locked
Remove Mail Forwarding of a Shared Mailbox RRS feed

  • Question

  • Hi,

    We have a shared mailbox in Exchage 2007 which forwards messages to a number of employees when a message is received.  I would like to stop this from occuring.

    I have checked the Mail Flow settings Tab of the mailbox and there are no users selected.  I have also tried running the following command in powershell.

    Set-Mailbox -Identity "Projects & Sales" -ForwardingAddress "someone@mycompany.com" -DeliverToMailboxAndForward $false

    Despite running this command messages are still being forwarded.

    Suggestions welcomed.

    Thanks

    Tuesday, September 18, 2012 8:53 AM

Answers

  • On Wed, 19 Sep 2012 21:11:08 +0000, Agilbert2003 wrote:
     
    >I have followed the instructions provided by Evan (thanks), however let me restate that this is a shared mailbox.
    >
    >When I Right-click ‘Inbox’, and then click ‘Open Associated Contents Table’ (which contains the hidden messages of the Inbox).
    >
    >There isn't an item named IPM.Rule.Message as a Message Class
     
    If the user is disabled, enable the user. Create a profile and open
    the mailbox. Check the rules. If you don't see ay rules then exit
    outlook and then start outlooks by "Start -> Run -> Outlook.exe
    /Cleanrules". See if that fises your problem. When you're done,
    disable the user if it was disabled to begin with.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Wednesday, September 19, 2012 9:54 PM

All replies

  • Can you check whether you have any transport rule configure in exhange.

    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com

    Tuesday, September 18, 2012 11:31 AM
  • No there is nothing configured in Transport Rules.
    Tuesday, September 18, 2012 7:56 PM
  • Are you sure its the shared mbx which is forwarding or another recipient

    Check cor any rules or hidden rules for that mbx.

    ?


    Sukh

    Tuesday, September 18, 2012 11:30 PM
  • it's definitely the mailbox. As soon as I send the message it is then forwarded on to 3 other mailboxes.

    Sorry not sure where to check for hidden rules. I can't see them in the properties of the of hte mailbox.

    Wednesday, September 19, 2012 7:01 AM
  • Hello,

    You can use MFCmapi to check the hidden rules:

    How to delete corrupted and hidden rules from a single mailbox in Outlook 2003

    http://support.microsoft.com/kb/924297

    Delete Corrupted, Hidden or Stale rules from mailbox with MFCMapi (just for reference)

    http://exchangeshare.wordpress.com/2008/04/10/delete-corrupted-hidden-or-stale-rules-from-mailbox-with-mfcmapi/

    Thanks,

    Evan Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com


    Evan Liu

    TechNet Community Support

    Wednesday, September 19, 2012 8:41 AM
    Moderator
  • See the above on how to check for rules.

    Sukh

    Wednesday, September 19, 2012 8:53 AM
  • Hi,

    I have followed the instructions provided by Evan (thanks), however let me restate that this is a shared mailbox.

    When I Right-click ‘Inbox’, and then click ‘Open Associated Contents Table’ (which contains the hidden messages of the Inbox).

    There isn't an item named IPM.Rule.Message as a Message Class


    • Edited by Agilbert2003 Wednesday, September 19, 2012 9:11 PM
    Wednesday, September 19, 2012 9:11 PM
  • On Wed, 19 Sep 2012 21:11:08 +0000, Agilbert2003 wrote:
     
    >I have followed the instructions provided by Evan (thanks), however let me restate that this is a shared mailbox.
    >
    >When I Right-click ‘Inbox’, and then click ‘Open Associated Contents Table’ (which contains the hidden messages of the Inbox).
    >
    >There isn't an item named IPM.Rule.Message as a Message Class
     
    If the user is disabled, enable the user. Create a profile and open
    the mailbox. Check the rules. If you don't see ay rules then exit
    outlook and then start outlooks by "Start -> Run -> Outlook.exe
    /Cleanrules". See if that fises your problem. When you're done,
    disable the user if it was disabled to begin with.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Wednesday, September 19, 2012 9:54 PM
  • Thanks Rich for your reply, however this is a shared mailbox not a single user. 
    Wednesday, September 19, 2012 10:10 PM
  • not sure what you mean with your last post, even if its a shared mailbox it will have a usr asciayrd with, check the rules first.x

    Sukh

    Wednesday, September 19, 2012 11:12 PM
  • ahh... my mistake.

    You are correct. Logged in using the user credentials for this mailbox and was able to remove rules.

    Thanks

    Wednesday, September 19, 2012 11:47 PM
  • On Wed, 19 Sep 2012 22:10:03 +0000, Agilbert2003 wrote:
     
    >Thanks Rich for your reply, however this is a shared mailbox not a single user.
     
    You can't have a mailbox without a user. :-)
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, September 20, 2012 12:50 AM
  • ahh... my mistake.

    You are correct. Logged in using the user credentials for this mailbox and was able to remove rules.

    Thanks

    Is it working well now?

    If it is working now, please help to close the thread.

    If the issue persists, please post you check result.

    Thanks,

    Evan Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com


    Evan Liu

    TechNet Community Support

    Friday, September 21, 2012 9:55 AM
    Moderator