locked
Shared mailbox - print name in header RRS feed

  • Question

  • Hey,

    We have some users who have access to a shared mailbox. These users have full permissions (based on a group, not direct user permissions) to the mailbox and have them added manually into Outlook as a full account, so have access to the Archive mailbox too.

    This way, when emails are printed that are in the shared mailbox, the header has the shared mailbox name, rather than the current user's name. How do we change this behaviour?

    What is interesting, is that if I set user permissions to the mailbox rather than groups, Outlook obviously auto-adds the mailbox, and this way it shows the current user's name in the print header. Also, if I add the mailbox as an additional account, the current user's name shows but they then lose access to the Archive mailbox.

    Bit of a weird one this! Typical MS!

    Monday, January 15, 2018 4:03 PM

Answers

  • Hi Lanky,

    Thank you for your update.

    As we discussed, The shared mailbox which is added as additional mailbox has different features from auto-mapped to the primary user mailbox. Currently, I haven't found any official articles about this. I'm afraid that there is no built-in option in Outlook to realize it.

    Thank you for your understanding and support.

    Regards


    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    • Edited by Perry-Pan Wednesday, January 31, 2018 12:47 AM
    • Marked as answer by Lanky Doodle Thursday, March 8, 2018 3:59 PM
    Wednesday, January 31, 2018 12:47 AM

All replies

  • Hi Lanky,

    >>when emails are printed that are in the shared mailbox, the header has the shared mailbox name, rather than the current user's name. How do we change this behaviour?

    According to my research, I’m afraid that there is no such a built-in option in Outlook to change or remove the name or message header at the top of the printout.

    As a workaround, you could open the message via browser and change the header information in the print setting. I’ve tested this in my Outlook and please refer to my steps below.

    1. Open the message. Go to Actions > View in Browser.

    2. Click Tool icon and then choose Print > Print setup…

    3. Roll down to choose Custom under Header section. Type the header name and click ok.

    4. Check the Print preview and then print the message.

    Hope this is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, January 16, 2018 8:52 AM
  • Thanks Perry.

    Do you know/can you find out why then if the mailbox is auto-added (I believe this is referred to as auto-mapping) with user accounts having full permissions it works as I want - it shows the Outlook users info, not the mailbox. But when groups have full permissions and the mailbox in manually added it shows the mailbox's info.

    Is this by design or a bug? It is the same in Outlook 2010 - 2016.

    I know about the open in broswer workaround but unfortunately that would not be acceptable for my users as we literally print every sent/received email so our physical files match the email conversations.

    Thanks again.

    Wednesday, January 17, 2018 2:24 PM
  • I've just thought of something. In Outlook, can you use variables in the header/footer?

    I know this doesn't work. But can you use other variables?

    Wednesday, January 17, 2018 2:36 PM
  • I've seen that you can, using the buttons at the middle bottom of the dialog. [User Name] is the one.

    However, and this is not super critical, can you move just the default header up so that my custom one sits just above the header line?

    Wednesday, January 17, 2018 10:17 PM
  • Hi Lanky,

    In fact, this is an expected behavior. The shared mailbox which is added as additional mailbox is different from auto-mapped to the primary user mailbox. Outlook exposes certain features when the mailbox is added as normal (primary or additional) account like Private Items, Send on behalf/send As permissions. This may leads to this situation.

    If you want to add custom header, you may follow the steps below as a workaround.

    1. Go to File > Print. Double click Memo Style to open the Page Setup.

    2.Under Format, click Front of Title and change it to 1 pt. Webdings.

    (When you set the font size to 1pt (type 1 in the size field, as it isn’t in the list), your name becomes basically unreadable especially when you’d also select a symbol font like Webdings, it results pretty much in a black line.)

    3. Under Header/Footer tab, type your custom header and then click OK.

    4. Check the Print Preview.

    Hope this is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Perry-Pan Monday, January 22, 2018 9:11 AM
    Thursday, January 18, 2018 8:59 AM
  • Hi Lanky,

    I am writing to see whether the above information is helpful. If the above information was helpful, could you please help mark it as answer so it will be easy for other forum members, who might have similar issues to find the useful one?

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, January 22, 2018 9:12 AM
  • Hello,

    Thanks for that. That's useful to know too.

    Another thing we have noticed with actually manually adding the account is that during reply to all, it includes the current users address.

    So:

    Email comes in from outside to Joe Bloggs and is say CC'd to Jill Bloggs
    The email to Jill is actually redirected to the shared mailbox via an Exchange transport rule, so does not exist in Jill's mailbox
    Jill replies to all from the shared mailbox and so because it's not her mailbox it includes her in the list of recipients

    That doesn't happen if the mailbox is auto-mapped. Is there any way of stopping this with a manually added mailbox?

    Thanks

    Monday, January 29, 2018 10:55 AM
  • Hi Lanky,

    Thank you for your update.

    As we discussed, The shared mailbox which is added as additional mailbox has different features from auto-mapped to the primary user mailbox. Currently, I haven't found any official articles about this. I'm afraid that there is no built-in option in Outlook to realize it.

    Thank you for your understanding and support.

    Regards


    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    • Edited by Perry-Pan Wednesday, January 31, 2018 12:47 AM
    • Marked as answer by Lanky Doodle Thursday, March 8, 2018 3:59 PM
    Wednesday, January 31, 2018 12:47 AM
  • Hello!

    I am actually having the reverse issue! It is showing the Exchange user's Contact name and not the Shared Mailboxes name? How can I switch this where when printing an email, it will show the Shared Mailbox name in the header instead? 

    Thanks! 

    Saturday, December 14, 2019 12:36 AM