none
The timesheet creation failed RRS feed

  • Question

  • Hi, 

    I know this question is often placed here, but I really need to find a solution for this. 

    All my EPM (Project Server 2013) users are facing this problem (see pic bellow), when creating a timesheet.

    And untill few days, all the already approved timesheets were able to be open (read mode), but now I have this error when try to open a timesheet:

    I already tryed to delete and re-create the timesheet, but I didn't get any success.

    After create the timesheet, I do a refresh, and I'm able to open the timesheet normally, but after sending the timesheet for approval, it's gone...

    Any one faced the same issue and was able to solve it?

    Thank you very much.

    Best regards.

    Wednesday, November 6, 2013 5:32 PM

Answers

  • Hello Vikram, 

    Thank you for your reply.

    October 2013 CU already installed.

    Meanwhile I found that, as far as I can understand, the issue is with project plans themselves.

    Explaining:

    I had some issue with project plan resources after migrate from 2010 to 2013.

    For migrated project plans, Project Professional 2013 didn't match the project resources with Project Server resources and didn't assign, all the already work submitted, to the Project Server resources, instead it created a new resources for the upcoming work and let the "old resource" with the actual work.

    That provoke some sync problems with timesheets. But that problem is already solved.

    What I found now is that the old timesheets, already submitted or even approved, who has projects that had that issue with the "double resources", are the problem.

    After delete timesheet by timesheet, the error stops when all the timesheet that have projects with the related problem were deleted.

    I'll recreate all timesheets now, and verify if the issue persists.


    • Marked as answer by Ric MC Thursday, November 7, 2013 2:09 PM
    • Edited by Ric MC Thursday, November 7, 2013 2:10 PM
    Thursday, November 7, 2013 8:50 AM

All replies

  • Hello Richard,

    Try installing August 2013 CU for both project and SharePoint server and then check the behavior.

    Here is the link.

    http://support.microsoft.com/kb/2817508


    Vikram Daruru - MSFT

    Thursday, November 7, 2013 6:23 AM
    Moderator
  • Hello Vikram, 

    Thank you for your reply.

    October 2013 CU already installed.

    Meanwhile I found that, as far as I can understand, the issue is with project plans themselves.

    Explaining:

    I had some issue with project plan resources after migrate from 2010 to 2013.

    For migrated project plans, Project Professional 2013 didn't match the project resources with Project Server resources and didn't assign, all the already work submitted, to the Project Server resources, instead it created a new resources for the upcoming work and let the "old resource" with the actual work.

    That provoke some sync problems with timesheets. But that problem is already solved.

    What I found now is that the old timesheets, already submitted or even approved, who has projects that had that issue with the "double resources", are the problem.

    After delete timesheet by timesheet, the error stops when all the timesheet that have projects with the related problem were deleted.

    I'll recreate all timesheets now, and verify if the issue persists.


    • Marked as answer by Ric MC Thursday, November 7, 2013 2:09 PM
    • Edited by Ric MC Thursday, November 7, 2013 2:10 PM
    Thursday, November 7, 2013 8:50 AM