none
problem with 'MSN MoneyCentral Investor Stock Quotes' in Excel

    Question

  • I have been downloading quotes into Excel using the "MSN MoneyCentral Investor Stock Quotes" connection. On December 23, 2014, this connection stopped working properly, now seems to be connecting to MSN homepage, and does NOT bring in the requested quotes. Do anyone have a solution or work around for this problem?
    Tuesday, December 23, 2014 6:55 PM

All replies

  • I have the same problem. I am glad that I am not the only one. I had just put a password on the file, and I thought that I caused the trouble.
    Tuesday, December 23, 2014 8:24 PM
  • Same problem for me too.  Began Dec 22nd.  Any news on when this will be fixed?
    Wednesday, December 24, 2014 4:11 AM
  • Hi All,

    Thank you for the feedback. We are aware of this issue and the PG team is working on the problem and will fix the issue in a short time.

    Thank you for the understanding.

    Regards,

    Steve Fan
    TechNet Community Support


    It's recommended to download and install Configuration Analyzer Tool (OffCAT), which is developed by Microsoft Support teams. Once the tool is installed, you can run it at any time to scan for hundreds of known issues in Office programs.


    Wednesday, December 24, 2014 6:17 AM
    Moderator
  • Same problem here.  I have been using MSN MoneyCentral for several years now and it worked great until 2-3 days ago.  It is great tool and I would hate to look for something else. 

    TechNet - please fix it soon!!

    Wednesday, December 24, 2014 6:00 PM
  • So what is meant by "will fix the issue in a short time"?  More specifics?
    Saturday, December 27, 2014 4:13 PM
  • Can we please have an update for an expected resolution to this problem?
    Monday, December 29, 2014 8:43 PM
  • Any update here MSFT? Should I just bail on excel/msn and go to google? This is frustrating. 
    Tuesday, December 30, 2014 6:13 PM
  • I've given up on MSN and now have replaced with Yahoo as source for info.
    Wednesday, December 31, 2014 2:15 AM
  • Could you please let me know how to do it?

    Thank you.

    Friday, January 02, 2015 3:57 PM
  • I too have resorted to using Yahoo in place of the MSN Money quotes.  I actually think it works better.   You can find out more at either of these sites:

    http://www.jarloo.com/yahoo_finance/
    https://pmstockquote.codeplex.com/

    I have put together a sample Excel spreadsheet that I could share if anyone wants it. Oh, this Yahoo alternative does require Excel2013.

    Thursday, January 08, 2015 1:30 AM
  • I would love to see the spreadsheet please. 

    Thanks. 

    Friday, January 09, 2015 2:36 AM
  • I ended up tired of waiting for Microsoft to fix the problem (and have suspicions that they might not even do it) and bit the bullet and bought the Technitya Excel Add-in from http://technitya.com/ for $67 USD which includes a 1 user llifetime license with unlimited 24 by 7 email and phone support .

    It works on Excel 2003 and later versions which is perfect since I use the former and people that access the spreadsheets I create use later versions. I just tested it out with Yahoo quotes and it works beautifully, and also has many other features I may use. 

    What an asinine move by Microsoft to disable the link and then not fix it almost 3 weeks later when hundreds of thousands (or maybe millions) of spreadsheets rely on it. 

    Also, Yahoo cannot disable the link as it is not dependent on Yahoo but the 3rd party software. They'd have to stop providing quotes totally for it to not work, which will never happen (I don't think). 





    • Edited by Toronto Guy Friday, January 09, 2015 4:24 AM
    Friday, January 09, 2015 4:21 AM
  • I'll send you my Excel file if you'd like. How do I go about doing that? Do you want to post your email here?
    Sunday, January 11, 2015 4:51 PM
  • One month ago you told PG team would fix the issue in a short time. Do you have any update about that?

    Thank you


    • Edited by ramalobe Friday, January 23, 2015 8:49 AM
    Friday, January 23, 2015 8:48 AM
  • They seem to have PARTIALLy fixed the problem.  You can now retrieve most stock quotes, but it is still broken for EFT quotes and most foreign stocks. 

    For example, GSK (Glaxo Smith Kline) returns the quote from the London exchange instead of the New York exchange. 

    Also, EFTs are not handled.  For example, PGP, which used to return information on the PIMCO Global StocksPLUS & Income fund now returns information about Proctor and Gamble from the Paris exchange.

    Tuesday, January 27, 2015 7:33 PM
  • Hi Mike - You say they have PARTIALLY fixed the problem...  where are you getting this to work?  When I try to refresh my old Excel spreadsheets that were retrieving values via the Data Connection MSN MoneyCentral Investor Stock Quotes, it is still returning "data not available" for all the Mutual Fund symbols I have loaded.
    Friday, January 30, 2015 1:41 AM
  • Partial solution here:

    http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2014/12/11/forms-controls-stop-working-after-december-2014-updates-.aspx

    As reported earlier, the %Change column is now 100 times larger than it should be. 

    I use the quotes in other pages of my Excel program as a basis for other Excel calculations.  Some of the cells in my it-worked-before-the-December-update worksheet now show "#REF!" errors because "MSN MoneyCentral Investor Stock Quotes" in Excel is not getting all of the quotes (missing about 10% of the quotes I used to get).  Each time it misses a quote, the missing quote causes all of the following requested quotes to move one row higher.  That throws my whole spreadsheet off because references to cells in "MSN MoneyCentral Investor Stock Quotes" now grab the wrong quote or the Terms of Use or copyright notice below all of the quotes.

    It helps to remove any spaces from the quote parameters.

    Use "amzn,wmt,cost", instead of "amzn, wmt, cost".

    • Edited by GeezerNerd Sunday, February 01, 2015 4:43 PM New discovery
    Sunday, February 01, 2015 4:29 PM