Shared Mailbox send as in outlook 2013 stuck in delegate's outbox folder RRS feed

  • Question

  • I have Outlook 2013 connecting to Exchange 2013 in Online Mode and not cached mode. Using ECP, I have a user full access rights and send as rights to a shared mailbox. The user can see,delete, and read emails in the shared mailbox. When the user tries to send mail as the shared mailbox, the email is getting stuck in the user's outbox folder and never sends. Not even after manually clicking on send and receive. I also do not have the registry key DelegateSentItemsStyle

    Any idea how I can fix this?

    Tuesday, April 23, 2013 8:35 PM


  • Hi there,

    Please try in Outlook cached mode.

    Hope it is helpful.

    Fiona Liao
    TechNet Community Support

    Cached mode work. Is there any other way around this without using cached mode?
    • Marked as answer by dom8925 Thursday, April 25, 2013 10:02 PM
    Wednesday, April 24, 2013 1:30 PM

All replies

  • Hi there,

    Please try in Outlook cached mode.

    Hope it is helpful.

    Fiona Liao
    TechNet Community Support

    Wednesday, April 24, 2013 9:01 AM
  • Hello,

    We have exactly the same problem here and I could be more specific for my case:

    Exchange 2013 with CU1 installed.

    1) with the SendAs function, the message is stuck in the outbox folder

    2) with the SendOnBehalf function, the message is delivered but contains an incorrect smtp address; in fact the field is replaced by content of the attribute "legacyDN" from the AD (CN=xxxxxxx,OU=xxxxxxx,xxxxxxx)

    On both case this problem is affecting Outlook 2010 and Outlook 2013 as sending client and not OWA client

    On both case we see that activating the cache mode for Outlook is a workaround on this problem; but it creates other problems like allocating GB of storage for .OST files (in particular if an user add other's people accounts in the client).

    On both case we see that purging the auto-complete (in Outlook or with MFCMAPI) cache does not fix the problem.

    We have to deploy Exchange 2013 the next week-end for 120 users. We are researching an other and much better workaround. We will at least deploy a GPO to configure cache mode properties if this is the only workaround.

    I would be very happy to have a fix for this rapidely. We have now open a SR (113040410339300) by Microsoft but without any success at current time.



    • Proposed as answer by Valery Tyurin Saturday, October 5, 2013 6:16 PM
    Wednesday, April 24, 2013 1:06 PM
  • Hi there,

    Please try in Outlook cached mode.

    Hope it is helpful.

    Fiona Liao
    TechNet Community Support

    Cached mode work. Is there any other way around this without using cached mode?
    • Marked as answer by dom8925 Thursday, April 25, 2013 10:02 PM
    Wednesday, April 24, 2013 1:30 PM
  • Answer from microsoft support :

    I have tested the issue at my lab environment and I have the same issue with yours. There is a bug on this issue based on my research on our internal data. Please wait for some time and it will be fixed later. Thanks for your patience and time.

     After asking when this will be fixed :

    I have submitted the feedback about this issue to Microsoft Exchange 2013 product Team and if I get any reply from them, I will update it to this post. Thanks for your understandings and time.

    Thursday, April 25, 2013 9:59 PM
  • For information, in the case of "SendOfBehalf" message, we get always 3 error messages in the application event log in sequence:

    1) Event ID 4007 Rules

    Transport engine failed to evaluate condition or apply action. Details: 'Organization: '' Message ID '<bf7dca790f774a76b14d96e697af239c@EXCHMB.dsa.dom>' Rule ID '361cd6ea-84a8-42f9-a201-3e4906295fe3' Predicate 'senderAttributeContains' Action ''. ArgumentOutOfRangeException Error: System.ArgumentOutOfRangeException: The address '/o=Devi/ou=Exchange Administrative Group /cn=Recipients/cn=ec91c813c8a34033bf384bb2174d33c0-yankee1' is not a valid SMTP address.

       at Microsoft.Exchange.MessagingPolicies.Rules.TransportUtils.UserAttributeContainsWords(TransportRulesEvaluationContext context, String user, String[] attributeList, String tagName)

       at System.Linq.Enumerable.Any[TSource](IEnumerable`1 source, Func`2 predicate)

       at Microsoft.Exchange.MessagingPolicies.Rules.AndCondition.Evaluate ...

    This would say that the smtp address is already fitted wrong with the legacyDN by the Outlook client (when entry was taken from the GAL ?) 

    2) Event ID 10003 Poison Message

    3) Event ID 4999 General

    For the "SendAs" case, no event log in Exchange as the message is stuck already in the Outlook client.


    Friday, April 26, 2013 9:28 AM
  • Do you get any news about this case?
    I've also opened a call at Microsoft since two weeks but with no result.
    Tuesday, May 7, 2013 7:18 AM
  • I have the same problem and i cant enable the Outlook cached mode on my Terminal Server. I have to use the online mode because i dont have free space to allocating all GB's of storage for .OST files.
    Wednesday, May 8, 2013 7:57 PM
  • This is a known issue with Outlook in online mode, only workaround is to enable cache mode. If you have a good business case, open case with Microsoft support to pursue a fix.
    Monday, May 13, 2013 4:35 PM
  • If this is a known issue, i don't think that i have to open a case. If Microsoft offers this product with a online mode, they have to support without a case to send a fix. It's not a isolate case, and affects everyone that buy the exchange. The option of online mode is offers in this product, if dont work with online mode, don't sell with this option or just solve this problem and and release the fix to all.
    Monday, May 13, 2013 8:40 PM
  • Hi,

    We still does not have a better solution from Microsoft for this issue. So we added:

    - a 300GB HDU (no Raid) to store the cache of the users in off-line mode (.ost files)

    - we have designed a group of users that absolutely need for now the SendonBehalf and SendAs features

    - for this group we have pushed by GPO the "force cached mode", the location of .OST and the fact that additional mailboxes loaded in Outlook are NOT cached (to limit the cache). This works properly.

    - we use terminal server, so we decided that users does not need to have more than 1 session opened but may use any of the TS available so we have set only 1 cached files location, independant of the user profile (otherwise you get error loading outlook if the cached .ost files are already opened by an other session)

    - we started production for 120 users mailboxes 2 weeks ago, with 40 users with the cache active, and it seems to work so until better solution

    We also regret that this bug, which has been reproduced by Microsoft according to the man in charge the service request we opened, is still not resolved. For a more important deployement it could be a major isssue.


    Wednesday, May 15, 2013 9:30 AM
  • Microsoft has closed my case, they will fix this issue in CU2.
    Tuesday, May 21, 2013 2:50 PM
  • Hi All,

    Have the exact same issue, large number of users on Citrix that need to be able to send emails with different FROM addresses (more than one). My only little bit of success was adding all the FROM email addresses (departments) from the GAL to a users Contacts. I set the address book then to first check in the users contacts (by default it was the GAL). So I create a new email, select FROM via the contacts I just added and it works. What doesn't work though is doing it again, using the dropdown menu/history next to the FROM button. If I select a FROM address via the drop down I get "you do not have the permission to send on behalf of this user". If I press the FROM button, go to the user's contacts, select a FROM email address and send the email it works, again and again. If I select it via the FROM dropdown it does not. Now, this along with the omission of the very usefull DelegatesSentItemsStyle (option to have outbound emails in the delagates Sent Items as well as the shared mailbox's) is giving me and my company headaches. The SentItemsStyle issue I have managed to emulate via transport and mailbox rules, this FROM issue though I can't. It was nice finding this post though as I was going crazy, trying a lot of weird and dangerous things.



    Friday, June 28, 2013 5:28 PM
  • OK guys, I think I have a pretty good workaround after "refining" my previous workaround. I selected all the contacts from the GAL that I would like to be able to send email as and added them to the user's contacts. I then opened the Address book's properties and removed the GAL from "check address lists in this order", after selecting Custom of course. This way I can fire up a new email, click FROM-Other email address and type in there any part of the FROM addresses I have in my contacts, press OK and then send. This way no GAL lookup is done (it seems). The only thing that doesn't work is using the history dropdown of the FROM button, this seems to have the same effect as selecting a contact from the GAL.

    Hope this helps,


    • Proposed as answer by Vectivus Monday, July 1, 2013 2:57 PM
    Monday, July 1, 2013 2:57 PM
  • We have a simular problem but are solution is :

    don't create you outlook profile via outlook but create it via Start/configuration/e-mail. Add all e-mail account to the new created outlook-profile.  (best is to delete the existing outlook-profile)

    We don't now the difference between creating via outlook are creating vin start/configuratio.e-mail but all are hanging mailproblems are solved.

    Hope this helps;


    Tuesday, July 2, 2013 11:47 AM
  • I have tried your method, but when I try to select the address from my contacts list i get " Cannot perform the requested operation. the coomand selected is not valid for this recipient"

    Any clues?

    I have also tried the method  below (manual config)  and then it just stays in the Outbox-

    Really getting frustrating as we need to send as-  but cannot load the terminal server with all these OST's in cached mode.

    You would expect something a little more efficient considering the thousands of dollars spent on this.

    Wednesday, July 3, 2013 5:47 PM
  • Hi a0J,

    I have been using this method for days now on several users, testing SEND AS before we go live, so at least in my environment it works as described 100%. I can see your error popping up around the internet so something else must be wrong in your environment. I would suggest you create a brand new user/mailbox and:

    - Switch Outlook to online mode

    - Go to the GAL, select the FROM contacts you would like to send as, right click and select add to contacts.

    - Then go to Address book (in inbox), go to tools-options and under "when sending email, check these address lists first" select custom, remove the GAL and leave only the user's Outlook contacts in there. The last bit is important, as I observed a case where a user had two accounts in Outlook (an Exchange one and a POP3 one), with two Contact folders, both set to be used as an address book and my trick was not working. I had to remove everything but the Exchange mailbox Contacts and Suggested Contacts for it to work.

    Again I would suggest you tried this with a "clean" user (mailbox, .nk2 cache file). Our goal is for Outlook to use the users contact whenever its trying to validate/lookup the FROM address/display name.

    If it works with a brand new user, then you can begin troubleshooting why it doesn't work with an old one.

    • Edited by Vectivus Thursday, July 4, 2013 10:46 AM addressed to wrong person (Peter instead of a0j).
    Thursday, July 4, 2013 10:45 AM
  • Hi ! Someone try CU2 for this bug ?



    Thursday, August 22, 2013 5:10 PM
  • Hi, CU2 seems to have corrected this bug for us, I have reverted to how things were before my workaround and SendAs works fine now. If only we could get DelegateSentItemsStyle asap I would be happy.Best Regards

    Thursday, August 22, 2013 9:43 PM
  • Yes working ok now with CU2 installed :)
    Friday, August 23, 2013 12:18 PM
  • Yes working ok now with CU2 installed :)
    No need to use cached mode or the registry edit?
    Friday, August 23, 2013 1:33 PM
  • No, no tricks needed anymore, for SendAs to work,in Outlook in online mode.
    Sunday, August 25, 2013 9:58 AM
  • Yes working ok now with CU2 installed :)

    My version is Exchange 2013 RTM. It's delighted to hear that if CU2 can fix it.

    My client encountered the problem only have shared mailbox and it happened randomly.

    I tried re-created client outlook profile, add shared mailbox manually rather than auto-add by Exchange 2013.

    Both of the two method are fail. 

    My workaround is uncheck cached mode and no mail stuck in outbook.

    But the method would cause server loading heavy and unconvenience for roaming users.

    Is it any risk to upgrade to CU2 ? What shall I pay attention?

    Friday, August 30, 2013 11:37 AM
  • Yes, it works now for plain online mode, but with DelegateSentItemsStyle it's still confusing:

    The mail will be sent, but gets stuck in my outbox folder.

    Indeed it's not satisfying that there is no working way to have the DelegateSentItemsStyle behavior on server side, the reg key just seems to be a dirty client hack.

    Wednesday, September 4, 2013 12:17 PM
  • Hi,

    we work with Exchange 2013 CU2 and Outlook 2013 and our customers work with Exchange 2013 CU3. And it doesn't work fine. My Installation is "fine" working in Cache mode.

    Is there any official solution from MS?

    So many Posts and so few Solutions :-( -

    Hi MS-Team, why do you do good features broken again with every new version?

    Best regards!

    • Edited by Tobia Monday, February 3, 2014 11:37 AM
    • Proposed as answer by Qayoum Monday, February 17, 2014 4:50 AM
    • Unproposed as answer by Qayoum Monday, February 17, 2014 4:50 AM
    Monday, February 3, 2014 11:32 AM
  • Removed Full Access permissions, then reassigned Full Access permissions with AutoMapping disabled
    via EMS.

    Disable Outlook Auto-Mapping with Full Access Mailboxes:

    Issues that can occur when you add multiple Exchange accounts in the same Outlook 2010 or
    Outlook 2013 profile:

    Monday, February 17, 2014 4:51 AM
  • I cache it works fine, Its working for me I my lab.
    Monday, February 17, 2014 4:52 AM
  • This issue is been fixed in CU2 or Later.
    Tuesday, February 18, 2014 4:55 AM
  • I have the SAME issue with Exchange 2013 SP1 !!!

    I have Exchange 2010 sp3 and Exchange 2013 sp1 (fresh in new VM) in coexistence - if i move mailbox to 2010 - everything is working. If i move mailbox back to 2013 - i have same bug. I have tried to create new mailbox - bug still there.

    My steps:

    1. Create Distribution Group in Exchange Ad. Center 2013

    2. Set Send As in delegation.

    3. Set mail address for this group.

    4. Trying to send mail from it

    5. Message stuck in outbox.

    6. Delete message  from outbox.

    7. Move mailbox to Exchange 2010

    8. Trying to send mail again - it works!!

    9. But i want to use 2013 and with no cached mode :)

    • Edited by 06a62412e3 Wednesday, March 19, 2014 9:39 AM
    Wednesday, March 19, 2014 9:13 AM
  • Same Problem here:

    Exchange 2013 SP1 & Outlook 2013 SP1. Our client uses Citrix and PC's. It is NOT DONE to use Cached Mode. Some profiles have 50GB!!!!!!!! Mailboxes. I do not know about you but our c-drives do not have TB's of data available to accomplish cached mode.

    What I find very weird is the fact that this problem exists since 2003. EVERY time MSFT makes a workaround after years of complaining of us. Why can't you just make it default with a NEW vesion of your products?

    This is just very annoying. 1 Year ago you said it would be fixed. Now SP1 is already out and it is still not fixed. Just hurry up!

    Friday, April 4, 2014 10:10 AM
  • Do not you think that adding some extra disk storage (it's really cheap these days) and swithching on the cached mode in Outlook  is the easiest way to solve the problem?



    Exchange and Outlook utilities at

    Wednesday, April 23, 2014 4:07 PM
  • it also works if you define download headers only, 3 months (GPO) and target only the ppl that hv shared boxes. 50GB will become 10GB. Until they fix this -weird- issue it's my only production workaround.
    Friday, August 29, 2014 7:11 AM
  • Hi,

    i had same issue in our enviroment:

    E2k13 CU15 on W2k12R2 (all patches).

    Domain Controller is also 2012R2.

    We migrated from E2k7 SP1. We have a Citrix-Terminal-Server-Enviroment with 16 TS. In E2k7-Version we deployed a GPO that set the registry-key "delegateSentItemStyle" for Outlook-Clients, to move sent emails to delegate's sent-Items-Folder. After Migration to E2k13 that GPO didn't touched.

    In Outlook-Profiles under new Exchange-Server emails which sent by "send as" keep stucking in outbox of senders profile, even their are received by recipients. I became mad for searching the reason. The switch -MessageCopyForSentAsEnabled $true allows me to copy sent emails to Sent-Items-Folder of shared Mailbox and senders Mailbox, but it still stuck in senders outbox.

    Cause of using roaming profiles in enviroment, cached mode where not an option.

    Many hours an many more Google-Searches later i got an idea: Whats happens if i just delete this Registry-Key? So i did it for a test-user and voilà: send-as emails finaly leave the outbox an move to sent-items-folder, like they shall.

    Reg-Key for Outlook 2013:


    Hope that could help somebody.

    Greetings from germany and sorry for bad english ;)


    Friday, February 3, 2017 11:21 AM