locked
Vista Home Premium Stopped Recognizing my USB Compact Flash drive RRS feed

  • Question

  • 1. I have a Sony Multi-card MRW62E-S1 USB card reader than I have been using for a couple years now to copy pictures from my compact flash card from my camera. It's worked fine for several years, but now suddenly it doesn't work. The card is a SanDisk Extreme III 2.0GB CompactFlash. Normally, I just take the card out of the camera, put it in this reader, and a drive pops up, and it all works fine.
    2. I've got Vista Home Premium with all the latest updates and service packs. 
    3. I have an HP Pavilion dv9000 laptop with 2 gigs of ram.
    4. The only changes are whatever updates Vista automatically pulls down. I haven't installed anything new in a long time.
    5. I start by plugging it into any USB port (doesn't matter which one. This same behavior occurs on all of them. Also, my other USB devices work fine in all these same ports, such as my printer, scanner, iPhone, iPod, etc.)
    6. Vista makes the noise about new hardware being connected
    7. The little LED light flashes a little, and then stays on solid
    8.  Vista sits there about three or four minutes and does nothing.
    9. If I wait long enough, like several minutes, the drive LED will flash again briefly
    10. Then the new drive letters will appear in the my computer window, when normally they appear in only a few secons. At this point, it the my computer looks like how it normally looks, with adding and F G H and I drives. Normally, i just double click on the F drive, and would work fine. It always shows all the driver letters, even though I don't have any media in any of the other slots in the multi function reader. 
    11. If I double click on the f: drive, it will sit there with an hour glass and that window will stop responding. Eventually, the only choice is to force it closed, and vista will let me restart windows explorer. It does restart okay.
    12. At this point, without rebooting, my other USB devices still work fine. I can still print a test page, for example. I can unlpug and replug other devices, and it works fine. 
    13. If I don't double click on the f: drive and instead, I just unplug it, Vista will make the disconnected hardware noise
    14. I tried looking for driver from Sony, but if you go to their website about this product, it says there are no firmware or drivers. That fits with my recollection when I bought it. It did not come with any drivers. I just plugged it in and it worked. It must be using Windows drivers. 
    15. I tried going to my device manager, and it shows the following in my portable devices: USB HS-CF Card, USB HS-MS Card, USB HS-S Card, and USB HS-xD/SM when this is plugged in.  There are no yellow exclamation marks. I tried clicking update driver on all of these, but it said I had the most current driver. I tried uninstalling each of these, rebooting, and windows detected them and put them back. It didn't make any difference, and the behavior is still the same.
    16. I tried opening the Universal Serial Bus Controllers, and uninstalling each one of these and rebooting. Windows detected all of them again, and put them all back. It didn't make any difference, and the behavior is still the same.
    17. I tried unplugging all my other USB devices, but it didn't make any difference. 

    Friday, July 31, 2009 4:20 AM