none
Can't access Internet even though everything seems to work RRS feed

  • Question

  • I have a problem with my Windows 7 Internet connection. 

    The problem is:

    Both (wired and wireless) connections have IP address provided by DHCP, subnet mask and default gateway and they both seem to be working fine, but I can't access the internet.

    Both my roommates have internet access with no problems, and the router password has not been changed.

    I have restarted the modem and no luck.

    I have restarted the router and no luck.

    I have restarted the computer and nothing.

    I have disabled and deleted both network adapters, and re-installed them and no luck.

    I did ipconfig and I can see al the configuration and it looks fine.

    I did ipconfig /release  and ipconfig /renew and no luck.

    I have McAfee's firewall, but it's working fine and doesn't say anything about viruses

    Any ideas what else I can do? I really wouldn't like to format my machine...

    Monday, August 27, 2012 5:37 PM

Answers

  • Hi,

    Try:

    1 - Open command prompt as Administrator by clicking on Start > All Programs > Accessories > System Tools > (Right Click) Command Prompt and select Run As Administrator

    2 - Run the following command: netsh winsock reset   and press enter

    3 - Reboot the PC

    4 - When rebooted as per Step 1, Open command prompt in Admin mode

    5 - Run the following command: ipconfig /flushdns

    Kind Regards,

    Martin


    If you find my information useful, please rate it. :-)

    • Proposed as answer by STDNS Wednesday, August 29, 2012 12:19 AM
    • Marked as answer by Juke ChouModerator Thursday, September 6, 2012 5:06 PM
    Monday, August 27, 2012 11:41 PM
  • You might try disabling or uninstalling McAfee's firewall.  Appears to be a number of users reporting similar issues in McAfee's forums recently.

    https://community.mcafee.com/message/251649

    Monday, August 27, 2012 7:48 PM
  • Hi,

    First of all, you should make sure if the router can get a public IP address,  this information can be found at your router.

    If yes, there is no problem with your router. Try to Ping from your Windows 7 client to your gateway.

    If Ping is no problem, try to refresh your DNS. Please open your CMD with administrator right and type the command “ipconfig /flushdns”.

    If the issue persist after all the suggestion, please set your DNS manually for check. Please right click network icon>Open network and share center>

    Chang adapter settings>Select local Area Connection>Properties>Internet Protocol Version 4(TCP/IPv4)>check under “Use the following DNS server addresses>Type 8.8.8.8 in Preferred DNS server and alternate DNS server>OK

    Finally, please make sure there are no issues with your ISP. Making a call to your ISP is also need.


    Your Name

    TechNet Community Support

    Wednesday, August 29, 2012 9:31 AM
    Moderator

All replies

  • You might try disabling or uninstalling McAfee's firewall.  Appears to be a number of users reporting similar issues in McAfee's forums recently.

    https://community.mcafee.com/message/251649

    Monday, August 27, 2012 7:48 PM
  • Hi,

    Try:

    1 - Open command prompt as Administrator by clicking on Start > All Programs > Accessories > System Tools > (Right Click) Command Prompt and select Run As Administrator

    2 - Run the following command: netsh winsock reset   and press enter

    3 - Reboot the PC

    4 - When rebooted as per Step 1, Open command prompt in Admin mode

    5 - Run the following command: ipconfig /flushdns

    Kind Regards,

    Martin


    If you find my information useful, please rate it. :-)

    • Proposed as answer by STDNS Wednesday, August 29, 2012 12:19 AM
    • Marked as answer by Juke ChouModerator Thursday, September 6, 2012 5:06 PM
    Monday, August 27, 2012 11:41 PM
  • Hi,

    First of all, you should make sure if the router can get a public IP address,  this information can be found at your router.

    If yes, there is no problem with your router. Try to Ping from your Windows 7 client to your gateway.

    If Ping is no problem, try to refresh your DNS. Please open your CMD with administrator right and type the command “ipconfig /flushdns”.

    If the issue persist after all the suggestion, please set your DNS manually for check. Please right click network icon>Open network and share center>

    Chang adapter settings>Select local Area Connection>Properties>Internet Protocol Version 4(TCP/IPv4)>check under “Use the following DNS server addresses>Type 8.8.8.8 in Preferred DNS server and alternate DNS server>OK

    Finally, please make sure there are no issues with your ISP. Making a call to your ISP is also need.


    Your Name

    TechNet Community Support

    Wednesday, August 29, 2012 9:31 AM
    Moderator