locked
SSL Certificate is not trusted on 2012 R2 Web Application Proxy in Firefox, intermediate certificates missing? RRS feed

  • Question

  • Hello,

    We have ADFS running on a Windows 2012 R2 server with https://sts.piramide.nl/adfs/ls as the URL for the Web Application Proxy. It works fine from Internet Explorer and Chrome, but not from Firefox.

    After doing an SSL check via https://www.digicert.com/help/, I found out that the intermediate certificates are not being transmitted. We've installed these certificates and they show up when I run "dir Cert:LocalMachine\My" in PowerShell, but somehow they are not being sent to the browser.

    I also tried updating the SSLCertificate on the Web Application Proxy server using the Set-WebApplicationProxySslCertificate -Thumbprint cmdlet, with the Thumbprint string for the sts.piramide.nl domain, but to no avail.

    Does anyone know how to publish these intermediate certificates (issues by thawte) on https://sts.piramide.nl/adfs/ls ?

    Thanks!


    Morgan - http://blog.morg.nl - @morgnl


    Friday, September 2, 2016 6:04 AM

Answers

  • Are your Intermediate certificates in the correct Certificate store? Intermediate certificatesshould be in the Intermediate Certification Authorities store
    Friday, September 2, 2016 8:47 AM

All replies

  • Are your Intermediate certificates in the correct Certificate store? Intermediate certificatesshould be in the Intermediate Certification Authorities store
    Friday, September 2, 2016 8:47 AM
  • That was it, the certificates were imported into the wrong store. Thanks a lot!

    Morgan - http://blog.morg.nl - @morgnl

    Friday, September 2, 2016 9:06 AM