locked
Loadbehaviour in the registry is 3 but addin fails to load RRS feed

  • Question

  • Hi all,

    I have sequenced application that creates addin in Word,Powerpoint Excel and Outlook.

    It install below applications

    1. Dot Net 3.5 SP1

    2.Visual 2005 Tools for Office

    3.PIA 2010

    4.Outlook Addin

    5.Excel Addin

    6. Powerpoint addin

    7. Word addin

    I have created a separate package with Visual 2005 Tools , PIA  and all the addins tied into a single package.MS Office 2010 is also an sequenced application. DSC linked the addins shortcuts within respective osd of Office.

    When Word/Excel/Powerpoint/Outlook is launched i can see the addin as inactive , if i go to the COM-addins tab the addin states the Load at startuo and i enable the checkbox but it still does not load.

    The load behaviour is also 3 in the registry

    Can you please suggets what must be wrong and get it working.


    Regards, Shweta Karalkar


    Thursday, September 27, 2012 4:12 PM

Answers

All replies

  • Have you tried running ProcMon when you go in and enable the add-in. Within Office Add-ins?

    Also, might be a stupid question but have you installed all of these together locally on a machine and tested to see what the behavior is?

    Where are the add-ins located? Have you tried moving them to the correct respective folders within Office for startup?

    e.g XLStart for excel add-ins?

    What if you go in through a debug and open the .xla etc. Does it show you an error that way?


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Thursday, September 27, 2012 10:54 PM
  •  Hi Rorymon,

    Installing it manually works fine, it just when sequneced it fails to load.

    One more thing i noticed is within the sequenced Office application the COM-Addin points to C:\Program Files\.... whereas my virtual applications files are installed to Q:\<8.3 folder>\VFS\CSIDl_PROGRAM_FILES\....

    So i manually edited the registry to point to Q:\... , but it fails to load and this time the load beaviour is  chnaged to 2.

    Are VSTO addins handled differently when sequenced or extra steps need to be taken care of...

    Used Procmon , and it tries look for the VSTO files under sequened Office location Q:Office2010_x86\VFS\..... i manually copied the VSTO folder to the location it is searching for and changed the path of the AddinLoader.dll in the registry now pointing to the virtual loaction of the Office but no luck.

    i also installed the addins manually , keeping the Office 2010 virtual but it behaves the same way, addin is not loaded (LOCAL_INTERACTION_ALLOWED is TRUE)

    Looks like the media( dll files) has hard core entries.


    Regards, Shweta Karalkar



    Friday, September 28, 2012 2:28 PM
  • What happens when you use a debug command line to get into the virtual environment and manually launch the add-ons?

    http://rorymon.com/blog/index.php/troubleshooting-in-app-v/

    http://blogs.technet.com/b/appv/archive/2012/04/25/app-v-application-is-not-working-as-expected-troubleshooting-check-list.aspx


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Friday, September 28, 2012 2:42 PM
  • Even if manually launch the addins with the Virtual Office app, it does not load stating not  a valid office addin file.


    Regards, Shweta Karalkar


    Friday, September 28, 2012 3:05 PM
  • Hello,

    Can you create a single package that contains both Office and the plugins?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, October 2, 2012 8:49 PM
  • Hello,

    Same issue here. The VSTO addin for Excel 2010 (both packaged in 2 differents packages) is not starting at all.

    do you have any news?

    Friday, October 26, 2012 12:40 PM
  • Hello,

    What happens if you create a single-package (just repeating my suggestion above)?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, October 29, 2012 6:39 AM