the winrm client received an http status 504 from the remote WS-Management RRS feed

  • Question

  •  I have a fresh Windows 2012 64bit standard install,  I installed Exchange 2010 and installed all updates (9).  

    When i attempt to open EMC i get the following error " ServerName connecting to remote serverServerName failed with the following error message: the WinRM client received an HTTP status code of 504 from the remote WS-Management service.

    i get the error opening the EMC from the local server it self,  I have uninstalled the WinRM, and reinstalled it per a few Google searches.  I have also edited the Power Shell SSL virtual directory. 

    Sunday, September 6, 2015 2:41 PM


All replies

  • Hi,

    HTTP error 504 is related to gateway timeout, do you have configure proxy server in IE?
    If so, please remove it for testing: open Internet Option, switch to Connection, then remove proxy connection.

    Please check if there’s any further error event in the application log on the exchange server after reproduce the issue.
    Please find the related traces in the IIS log after reproduce the issue, which will help for troubleshooting.
    Please run ExBPA against exchange server for health and permission check.

    More details about Resolving WinRM errors, please refer to:

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    • Proposed as answer by Allen_WangJF Tuesday, September 15, 2015 9:30 AM
    • Marked as answer by Allen_WangJF Monday, September 28, 2015 1:53 PM
    Monday, September 7, 2015 5:21 AM
  • Removing proxy setting worked for me

    From an admin command prompt: NETSH WINHTTP RESET PROXY

    • Proposed as answer by Mavrik347 Thursday, February 7, 2019 9:29 AM
    Wednesday, October 3, 2018 10:29 AM
  • To check the winhttp proxy setting, you can run:

    netsh winhttp show proxy
    Wednesday, September 18, 2019 3:39 AM