locked
sort files by date accessed in explorer seems to be broken RRS feed

  • Question

  • In windows explorer if i set the view to sort by date accessed, the date the file was accessed never seems to change.

    Sunday, August 30, 2009 4:19 AM

Answers

  • It is possible that last access has been disabled on the file system.

    Open a command prompt and enter:

    C:\>fsutil behavior query DisableLastAccess

    If you get "DisableLastAccess = 1" it has been disabled.

    You can enable it by entering:

    C:\>fsutil behavior set DisableLastAccess 0
    • Proposed as answer by Brian Borg Saturday, September 5, 2009 5:04 AM
    • Marked as answer by Dale Qiao Saturday, September 5, 2009 2:00 PM
    Friday, September 4, 2009 4:48 AM

All replies

  • Hi,

    Thanks for posting in Microsoft TechNet Forum.

    Can you successfully sort files by other properties such as by Name, Date Modified? Please right click Sort by==>More==>uncheck the box in front of Date Accessed==>Click Ok==>sort the files by Name==>right click Sort by==>More==>check the box in front of Date Accessed==>click Ok==>sort the files by Date Accessed, and see if it works.

    Best Regards.
    Dale Qiao
    Monday, August 31, 2009 7:46 AM
  • Yes i can sort by name and date modified, i can also sort by date accessed.
    The problem is that the date accessed value doesn't ever change.

    example:
    I have a folder full of mp3 files.
    When i play one of these files the date accessed value does not change.



    Thursday, September 3, 2009 11:43 PM
  • Yes i can sort by name and date modified, i can also sort by date accessed.
    The problem is that the date accessed value doesn't ever change.

    example:
    I have a folder full of mp3 files.
    When i play one of these files the date accessed value does not change.




    Those mp3's wouldn't happen to be on a USB drive would they?  FAT file systems do not support date accessed.
    Thursday, September 3, 2009 11:54 PM
  • They are on an NTFS hard drive.

    Friday, September 4, 2009 4:25 AM
  • It is possible that last access has been disabled on the file system.

    Open a command prompt and enter:

    C:\>fsutil behavior query DisableLastAccess

    If you get "DisableLastAccess = 1" it has been disabled.

    You can enable it by entering:

    C:\>fsutil behavior set DisableLastAccess 0
    • Proposed as answer by Brian Borg Saturday, September 5, 2009 5:04 AM
    • Marked as answer by Dale Qiao Saturday, September 5, 2009 2:00 PM
    Friday, September 4, 2009 4:48 AM
  • Yes that was the problem.
    It is working correctly now.
    Thank You!

    I dont know of anything i would have done to disable it, maybe it is disabled by default?

    Saturday, September 5, 2009 5:01 AM