locked
Unable to add calendar permissions using EMS RRS feed

  • Question

  • Hi all.

    I'm experiencing some troubles when using the Add-MailboxFolderPermission cmdlet with EMS in Exchange 2010.

    I'm using a script that gives everyone in two AD-groups reviewer permissions to eachothers calendars, this works fine for most of the users, however, when trying to add some users to other users calendars, I get an error message.

    The first error message reads: 

    [PS] C:\>add-mailboxfolderpermission -Identity randomusername:\Calendar -AccessRights Reviewer -User username

    The user "username" was found in Active Directory but isn't valid to use for permissions. Try an SMTP address instead.
    + CategoryInfo          : NotSpecified: (0:Int32) [Add-MailboxFolderPermission], InvalidExternalUserIdException
    + FullyQualifiedErrorId : B5C8094F,Microsoft.Exchange.Management.StoreTasks.AddMailboxFolderPermission

    I then try to do the same thing, but using the same users smtp address instead. The errormessage then reads:

    [PS] C:\>add-mailboxfolderpermission -Identity randomusername:\Calendar -AccessRights Reviewer -User user.name@domain.com

    The user "user.name@domain.com" is either not valid SMTP address, or there is no matching information.
        + CategoryInfo          : NotSpecified: (0:Int32) [Add-MailboxFolderPermission], InvalidExternalUserIdException
        + FullyQualifiedErrorId : B5C8094F,Microsoft.Exchange.Management.StoreTasks.AddMailboxFolderPermission

    I can't find anything that seems obviously wrong, I need some help as to where to start looking.

    Regards,
    Erik

    Tuesday, February 18, 2014 2:48 PM

Answers

  • Indeed, after I ran Set-Mailbox -Identity username -Type regular, everything worked fine.

    The issue seemed to be that shared mailboxes cannot be granted permissions. I'll make sure that users will no longer receive shared mailboxes.

    • Marked as answer by mellanslag Wednesday, February 19, 2014 3:44 PM
    Wednesday, February 19, 2014 3:43 PM
  • That's correct because shared mailboxes have disabled user accounts.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, February 19, 2014 6:41 PM

All replies

  • Is username a mailbox-enabled user?  Have you tried "domain\username" or the account UPN?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, February 18, 2014 4:31 PM
  • Hello,

    Please follow the Ed's suggestion to check if the user is a mailbox-enabled user.

    Please try to specify the User parameter value that is Alias to check the result.

    If you have any feedback on our support, please click here


    Cara Chen
    TechNet Community Support

    Wednesday, February 19, 2014 2:26 AM
    Moderator
  • Thank you for your reply.

    I checked the users in EMS, and found a discrepancy in the affected users. They seem to have a Shared Mailbox instead of a User Mailbox (found with get-mailbox). Would this explain my issue?

    Wednesday, February 19, 2014 8:52 AM
  • Indeed, after I ran Set-Mailbox -Identity username -Type regular, everything worked fine.

    The issue seemed to be that shared mailboxes cannot be granted permissions. I'll make sure that users will no longer receive shared mailboxes.

    • Marked as answer by mellanslag Wednesday, February 19, 2014 3:44 PM
    Wednesday, February 19, 2014 3:43 PM
  • That's correct because shared mailboxes have disabled user accounts.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, February 19, 2014 6:41 PM