none
Can't retire physical disk after running Migratedatasourcedatafromdpm RRS feed

  • Question

  • I'm using DPM 2010.  In early November, I ran, I ran migratedatasourcefromdpm.ps1 to migrate to a new larger disk because my old storage pool disk is running out of room.  Since then I've watched (in Disk Management) as partitions slowly disappeared from the old disk.

    Now I've got one partition left and it's not being deleted.  How can I troubleshoot this and if necessary manually remove the remaining content so I can take out the disk?

    I looked in the partition and it has SQL database replicas dated mid-November.  If I look in the Protection tab, those SQL databases don't have any restore points available before mid-December, so it looks like those restore points on the disk are obsolete.

    Following another posting (not 100% sure it applies but couldn't hurt), I manually ran pruneshadowcopiesdpm2010.ps1.  It completed without error.  DPM is otherwise running normally and I don't see errors in the event log.

    I am comfortable running powershell scripts or even doing SQL queries but I could use some guidance as to what to look for.  I am about to do another migrate at a client and I'd like to understand better how to resolve problems like this before I proceed.

    Thanks,
    Mike Gilbert

    Thursday, January 6, 2011 7:31 PM

All replies

  • Hi,

    Not sure why the replica volume was not deleted by dpm - but since it sounds like the recovery point volume was deleted, then the replica is not needed any longer.

    If you confirmed that there are no recovery points left from before you did the migration for the data source that volume represents, then you can manually delete the volume using disk management and convert the disk back to a basic disk.  Once the disk is a basicdisk, you can safely remove it from the system and DPM will not be effected.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, January 6, 2011 9:07 PM
    Moderator
  • Hi Mike,

    Thanks for your advice.

    I went to delete the replica volume as you suggested.  The replica volume label is DPM-vol_bc565033-0299-4674-, which is mounted in DPM\Volumes\Replica\SqlServerWriter.

    I noticed there's a second volume, also labelled DPM-vol_bc565033-0299-4674-, ON THE NEW PHYSICAL DISK, which is mounted in DPM\Volumes\Diffarea\SqlServerWriter (ie it's a recovery point volume). Disk Management says this second volume is 99% empty.

    So it looks like the recovery point volume wasn't deleted so much as moved to the new physical disk.  I still suspect all this is obsolete - and if I look at the PG the replica path is a DIFFERENT volume mounted within Volumes\Replica\SqlServerWriter.

    So what do I need to do to properly clean all this up manually?

    1. You said above I should delete the replica volume and turn the disk back to a basic disk so I can delete it.
    2. Should I also delete the recovery point volume on the new disk?
    3. Should I remove one or both mount point folders within the Replica and Diffarea folders after I delete these volumes?

    Or given the existence of the recovery point volume does this mean I need to handle the situation differently?

    Thanks..

    Thursday, January 6, 2011 9:52 PM