locked
Sending sign & encrypted email via MS Outlook (Gmail is the server) RRS feed

  • Question

  • We configure our MS Outlook 2010 and my colleague on MS Outlook 2013.
     

    Connecting to Gmail and sending/receiving email is okay but .. 

    But have troublesome sending "sign" email (Comodo Cert) 

    We tried on using Google App Sync, POP and even IMAP.

    1) If we uncheck this portion "Send clear text signed message when sending signed messages"

    recipient will see a blank email, nothing in the email body or even a red ribbon.

    2) if we check "Send clear text signed message when sending signed messages", recipient is able to see it but is with .p7s attachment. 

    Any advise ? 
    Wednesday, March 16, 2016 12:48 AM

Answers

  • Hi,

    I'm afraid this is the expected behavior as Gmail doesn’t display a signed message properly. You have to check the "Send clear text signed message when sending signed messages" option when sending a signed email to Gmail. The .p7s attachment is associated with S/MIME and used to provide digital integrity during communication. You can just ignore it.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Proposed as answer by Steve Fan Tuesday, March 29, 2016 9:27 AM
    • Marked as answer by Steve Fan Wednesday, March 30, 2016 8:10 AM
    Thursday, March 17, 2016 8:46 AM
  • Thanks guys, found the issue.

    It is the Gmail Admin Console.

    Someone set to amend all outgoing email to have a Footer, had tried to disable it and it works. 

    • Marked as answer by Steve Fan Thursday, March 31, 2016 1:28 AM
    Thursday, March 31, 2016 1:25 AM

All replies

  • Hi,

    I'm afraid this is the expected behavior as Gmail doesn’t display a signed message properly. You have to check the "Send clear text signed message when sending signed messages" option when sending a signed email to Gmail. The .p7s attachment is associated with S/MIME and used to provide digital integrity during communication. You can just ignore it.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Proposed as answer by Steve Fan Tuesday, March 29, 2016 9:27 AM
    • Marked as answer by Steve Fan Wednesday, March 30, 2016 8:10 AM
    Thursday, March 17, 2016 8:46 AM
  • We manage to get it work.

    Eg. all incoming email via MS Outlook now is able see the Red Ribbon and able to see the encryption attachment.

    This is workable when our personnel gmail and yahoo mail is using Comodo Free SSL Cert.

    But in our office environment, we are using Corporate Gmail solution, then it will become .p7s in MS Outlook if we check  "Send clear text signed message when sending signed messages".

    We are wondering is this due to Gmail Admin console issue or Comodo free cert limitation, or even the MS outlook handing the incoming/outgoing problem.

    Thursday, March 17, 2016 9:00 AM
  • Thank you for the update. I'm afraid this issue is more related to Gmail. You may post a question to the Gmail forum for further assistance.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Wednesday, March 23, 2016 8:26 AM
  • Thanks guys, found the issue.

    It is the Gmail Admin Console.

    Someone set to amend all outgoing email to have a Footer, had tried to disable it and it works. 

    • Marked as answer by Steve Fan Thursday, March 31, 2016 1:28 AM
    Thursday, March 31, 2016 1:25 AM
  • Glad to hear that you have found the solution! Thank you for letting us know that.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Thursday, March 31, 2016 1:28 AM