none
Deploy Files In GPO with UAC enabled

    Question

  • Hello,

    I want to deploy multiple folders and some files in GPO with UAC enabled in Program Files (x86).

    my files must be updated when i change this.

    My files ares saved in this folder :

    \\SHAREDFOLDER\APPSNAME\PRODUCT1\FILE1.dat

    \\SHAREDFOLDER\APPSNAME\PRODUCT1\FILE2.dat

    \\SHAREDFOLDER\APPSNAME\PRODUCT2\FILE1.dat

    \\SHAREDFOLDER\APPSNAME\PRODUCT3\FILE1.dat

    \\SHAREDFOLDER\APPSNAME\PRODUCTxx\FILExx.dat

    Destination folder are :

    %HOMEDRIVE%\ProgramFiles (x86)\APPSNAME\PRODUCT1

    %HOMEDRIVE%\ProgramFiles (x86)\APPSNAME\PRODUCT2

    %HOMEDRIVE%\ProgramFiles (x86)\APPSNAME\PRODUCT3

    %HOMEDRIVE%\ProgramFiles (x86)\APPSNAME\PRODUCTxx

    i have make a script with robocopy and it works, but computer with UAC enable it doesn't works.

    robocopy command : robocopy \\SHAREDFOLDER\APPSNAME %HOMEDRIVE%\ProgramFiles (x86)\APPSNAME /S /R:1 /W:1

    I have check GPPreferences but i can't copy folder with files, i must create each line in GPP for each file and each folder.

    thanks for your help

    Tuesday, April 21, 2015 1:40 PM

All replies

  • > %HOMEDRIVE%\ProgramFiles (x86)\APPSNAME\PRODUCT1
     
    %homedrive%? This usually is the home folder of the user, and the user
    "should" have write access...
     
    > I have check GPPreferences but i can't copy folder with files, i must
    > create each line in GPP for each file and each folder.
     
    You can copy a folder if you put in the path with a trailing \
     
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Tuesday, April 21, 2015 2:31 PM
  • %HOMEDRIVE% = C: 

    i'ts environment variable. If the computer use D: as default letter, with %HOMDRIVE% it's works.

    i can't copy folder because UAC block the copy in C:\

    Tuesday, April 21, 2015 2:47 PM
  • > %HOMEDRIVE% = C:
     
    Oops, yes :)
     
    > i can't copy folder because UAC block the copy in C:\
     
    Then on the common tab, untick "run in logged on user's security context".
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Wednesday, April 22, 2015 3:28 PM
  • I can't use GPP because i have a lot of file to copy. GPP can't copy folder. Just copy a file, and i must add all file in GPP for copy in the computer. I want to find an other option.  if i can copy folder with subfolder and subfile it's good.
    Monday, April 27, 2015 8:27 AM
  • Hello,

    Use this in your .CMD or Batch File and test again:

    set __COMPAT_LAYER=RunAsInvoker
    robocopy \\SHAREDFOLDER\APPSNAME %HOMEDRIVE%\ProgramFiles (x86)\APPSNAME /S /R:1 /W:1

    Regards

    Monday, April 27, 2015 8:55 AM
  • Hi Oliopy,

    Would you please let us know if there's any update on this issue?

    If Patris_70's suggestion fix your problem?

    We'd like to hear from you.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 4, 2015 8:23 AM
    Moderator
  • I have try but it's doesn't work.

    it's odd that a simple file copy can not be done by GPO with UAC.

    I have search but i don't find how to copy a folder in C:\program files if UAC is enabled and without create a multiple GPP.

    Tuesday, May 5, 2015 8:34 AM
  • Hi oliopy,

    Thanks for the update. You can set a scheduled task and invove your command as a script, then got the 'run  with the highest proviliages' checkbox checked, this option will skip the UAC check. You can choose to run the scheduled task only once, please have a try and let me know the result.

    Also you can check the below link for more reference:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/60b66c63-fe64-46f2-ba38-137c64b666ea/deploy-files-in-gpo-with-uac-enabled?forum=winserverGP

    Hope It helps.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 11, 2015 2:20 AM
    Moderator
  • I up this post because we don't find solution for this issue.
    Tuesday, March 1, 2016 2:37 PM