locked
Inbound mail bouncing to old server, then new server RRS feed

  • Question

  • Hello,

     We're finishing up an Exchange migration, which involved going from Ex 2007 to 2013, and now 2013 to 2016.   The 2007 is decommissioned.

     We now have inbound mail coming in to our Ex 2016 server.   But I'm finding that inbound email, after it comes into Ex 2016 from our smarthost, is sent to our Ex 2013 server ("Mailtemp"), and then back to Ex 2016 ("Mail") server.    All mailboxes have been moved to our Ex 2016 server.  I can't figure out what's causing this.  Both servers have the same  receive connectors setup.

    [PS] C:\Windows\system32>Get-ReceiveConnector

    Identity                                Bindings                                Enabled
    --------                                --------                                -------
    MAILTEMP\Client Proxy MAILTEMP          {[::]:465, 0.0.0.0:465}                 True
    MAILTEMP\Default MAILTEMP               {0.0.0.0:2525, [::]:2525}               True
    MAILTEMP\Default Frontend MAILTEMP      {[::]:25, 0.0.0.0:25}                   True
    MAILTEMP\Outbound Proxy Frontend MAI... {[::]:717, 0.0.0.0:717}                 True
    MAILTEMP\Client Frontend MAILTEMP       {[::]:587, 0.0.0.0:587}                 True
    MAILTEMP\unix relay                     {0.0.0.0:25}                            True
    MAILTEMP\GFIFaxMaker                    {0.0.0.0:25}                            True
    MAIL\Default MAIL                       {0.0.0.0:2525, [::]:2525}               True
    MAIL\Client Proxy MAIL                  {[::]:465, 0.0.0.0:465}                 True
    MAIL\Default Frontend MAIL              {[::]:25, 0.0.0.0:25}                   True
    MAIL\Outbound Proxy Frontend MAIL       {[::]:717, 0.0.0.0:717}                 True
    MAIL\Client Frontend MAIL               {[::]:587, 0.0.0.0:587}                 True
    MAIL\GFIFaxMaker                        {0.0.0.0:25}                            True
    MAIL\Unix Relay                         {0.0.0.0:25}                            True


    [PS] C:\Windows\system32>Get-SendConnector

    Identity                                AddressSpaces                           Enabled
    --------                                -------------                           -------
    E2k13-internet                          {SMTP:*;1}                              True
    GFIFaxmaker                             {SMS:*;1, FAX:*;1, SMTP:smsmaker.com... True
    GFIFaxmaker1                            {SMS:*;1, FAX:*;1, SMTP:smsmaker.com... True

    Headers for an inbound message:

    Received: from MAILTEMP... (192.168.111.210) by MAIL....
     (192.168.111.15) with Microsoft SMTP Server (TLS) id 15.1.225.42 via Mailbox
     Transport; Thu, 19 May 2016 10:36:38 -0400
    Received: from MAIL.... (192.168.111.15) by MAILTEMP....
     (192.168.111.210) with Microsoft SMTP Server (TLS) id 15.0.1178.4; Thu, 19
     May 2016 10:36:38 -0400
    Received: from s12p02m081... (...) by MAIL....
     (192.168.111.15) with Microsoft SMTP Server (TLS) id 15.1.225.42 via Frontend
     Transport; Thu, 19 May 2016 10:36:38 -0400

    Thank you for any pointers!


    Maurice

    Thursday, May 19, 2016 3:51 PM

Answers

  • Hi Maurice,

    Is there NLB in your organization for Exchange?

    If there is NLB in your organization, please remove Exchange 2013 server from NLB pool.

    Then restart the following service on all Exchange servers:

    Microsoft Exchange Active Directory Topology 

    Microsoft Exchange Transport

    For a test, please shutdown Exchange 2013 for testing mail flow, but we suggest you do this step out of production time.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    • Marked as answer by jim-xu Monday, June 6, 2016 4:51 AM
    Monday, May 23, 2016 8:44 AM

All replies

  • Hi Maurice, 

    Welcome to our forum.

    By this issue, we could refer to the following steps to troubleshoot:

    1. Make sure Exchange 2016 was published to Internet instead of Exchange 2013, please try to check published rule on firewall
    2. Then uncheck “Anonymous User” on Exchange 2013 receive connector which receive email from Internet in the former

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Friday, May 20, 2016 5:38 AM
  • Hi Jim,

     Thank you for the suggestions.  Only the E2016 server is NAT'd through our firewall.   I did uncheck the Anonymous User on the E2013 receive connector for internet mail, but, am seeing the same behavior.

     My concern is what will happen when we decommission the E2013 server, if it will just "fix itself" or if internet mail is going to get stuck.

    Thanks


    Maurice

    Friday, May 20, 2016 7:45 PM
  • Hi Maurice,

    Is there NLB in your organization for Exchange?

    If there is NLB in your organization, please remove Exchange 2013 server from NLB pool.

    Then restart the following service on all Exchange servers:

    Microsoft Exchange Active Directory Topology 

    Microsoft Exchange Transport

    For a test, please shutdown Exchange 2013 for testing mail flow, but we suggest you do this step out of production time.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    • Marked as answer by jim-xu Monday, June 6, 2016 4:51 AM
    Monday, May 23, 2016 8:44 AM
  • Hi Maurice,

    Is there any update for this thread?

    If the above suggestions are helpful to you, please mark it as answer so that someone who has similar issue could find this thread as soon as possible.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Tuesday, May 24, 2016 10:07 AM
  • Hi Jim,

    No we are not using a NLB in our organization.   I will try shutting down the 2013 after hours and will follow up.

     I'm not sure if this is related, but, we have also found that when running the Exchange management shell from our client machine, it always connects to the Exchange 2013 server instead of the 2016 server.   I did  some searching on this issue but haven't found a solution that worked with E2016.


    Thanks



    Maurice

    Wednesday, June 8, 2016 1:39 PM
  • Hi Maurice,

    If that, please update Exchange 2013 and Exchange 2016 to the last.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Thursday, June 9, 2016 8:22 AM