locked
Lync Phones sometimes not getting an IP RRS feed

  • Question

  • Hi guys,

    I´m fighting with some Lync phones here, they are powered by PoE on an HPE Comware 5130 switch but out of 5 times they are booted, the DHCP works maybe once or twice. All the other times the phones stays without IP and needs to be rebooted, although I can see a lease being created on the DHCP. DHCP is a Windows Server and I have configured a DHCP Relay agent.

    Connecting a PC to the same port works in an instant, also connecting a PC to the integrated switch in the phone works as it should, but the phone itself mostly not.

    I tried several port configurations but nothing seems to change the behaviour. Once it is booted and received a DHCP address everything is OK and the phone is working until the next reboot. I can reproduce the problem on several switches using either a HP 4120 phone or a Polycom CX3000. also it makes no difference is the port is configured as hybrid (to put the PC in a different VLAN) or as access, directly in the voice VLAN. Playing with stp edge-port also has no effect (no wonder as STP is anyway disabled globally).

    Here´s one example interface configuration:

    interface GigabitEthernet2/0/7
    port link-type hybrid
    port hybrid vlan 56 tagged
    port hybrid vlan 8 untagged
    port hybrid pvid vlan 8
    undo voice-vlan mode auto
    voice-vlan 56 enable
    undo jumboframe enable
    qos trust dscp
    poe enable
    loopback-detection enable vlan 1 to 4094
    loopback-detection action shutdown

    I wouldn´t say its a DHCP issue as the same server is serving multiple VLANs successfully and as I said, one a phone received an IP, it works forever...

    Anybody has an idea?

    Thanks in advance

    Friday, May 19, 2017 5:05 PM

All replies

  • Hi LBH,

    Can you test on a plain old access port, removing all the additional hybrid/voice vlan config? I wouldn;t mind betting there's an issue with LLDP/CDP thats affecting the phone's ability to get an IP address. I've seen thi son multiple deployments.

    interface GigabitEthernet2/0/7
    port link-type access

    port access Vlan x

    On Polycom VVX series phones, it's easier to isolate LLDP/CDP as a possible cause of your issues, as they can simply be turned on/off from the phone's menu. Aries phones however... not much to configure.

    Cheers,

    Damien

    dmunified.com


    • Proposed as answer by Alice-Wang Monday, May 22, 2017 2:43 AM
    Saturday, May 20, 2017 12:51 AM
  • Hi Damien,

    already tried that, issue is the same also on a plain access port in the Voice-VLAN.

    And you´re right, troubleshooting Aries phones is fun...I also tried deactivating lldp on the phone ports, but without any change

    Monday, May 22, 2017 4:09 PM