none
Port forward computers connected to another via Windows Internet Sharing

    Question

  • I have a small server that I use to run some servers from time to time. The problem with that though is my computer, which stands next to the server, uses the only wireless card that I own. The card uses a USB port, so the Ethernet port on my computer isn't in use. I can set up the server to run off of my computer's Internet from an Ethernet cable, which works fine. I need to be able to open ports on the server, though, so I can run servers off of it and have them be able to be reached to the public. Any way of doing this, buying something being the last resort?
    Wednesday, February 05, 2014 11:54 PM

Answers

  •   You cannot run RRAS/NAT or ICS with only one NIC. You must have one NIC for the Internet connection and a different NIC for the private devices to connect to.

      The only exception is if the additional machines are virtual machines. In that case you can use a Microsoft Loopback Adapter as the private interface for NAT or ICS.


    Bill

    Thursday, February 06, 2014 1:18 AM
  •   You cannot port forward with ICS. ICS is a simple, cut-down version of NAT and cannot be configured. You would need a full version of NAT, which is not included in the client OS.

    You would need third party NAT for the client OS. Or simply buy a proper DSL modem/router and run a home network.

      (What does the wireless card connect to, anyway?)


    Bill

    Thursday, February 06, 2014 10:55 PM

All replies

  • Enable the 'Internet Connection Sharing' on the computer that is connecting to your network via wireless.

    - Chris Ream -

    **Remember, if you find a post that is helpful, or is the answer, please mark it appropriately.**

    Thursday, February 06, 2014 1:12 AM
  •   You cannot run RRAS/NAT or ICS with only one NIC. You must have one NIC for the Internet connection and a different NIC for the private devices to connect to.

      The only exception is if the additional machines are virtual machines. In that case you can use a Microsoft Loopback Adapter as the private interface for NAT or ICS.


    Bill

    Thursday, February 06, 2014 1:18 AM
  • He said his computer has two NICs.  The USB Wireless and the ethernet port that can be used to connect to the server.

    - Chris Ream -

    **Remember, if you find a post that is helpful, or is the answer, please mark it appropriately.**

    Thursday, February 06, 2014 1:40 AM
  • I can share the Internet to the server fine, it's just that when I run servers I need to open the ports. I'm just not sure how to go about that, since the server shows up as the same internal IP as my main computer. Would the best guess be to forward my computer's ports?
    Thursday, February 06, 2014 4:35 PM
  •   You cannot port forward with ICS. ICS is a simple, cut-down version of NAT and cannot be configured. You would need a full version of NAT, which is not included in the client OS.

    You would need third party NAT for the client OS. Or simply buy a proper DSL modem/router and run a home network.

      (What does the wireless card connect to, anyway?)


    Bill

    Thursday, February 06, 2014 10:55 PM
  • Just wanted to leave an update to a very old post, in case someone is still searching for this (like I did):

    It is possible to forward port in ICS (at least in Win 7 & 10), right in the "Settings" button where you activate connection sharing.

    Best shown in: http://www.utilizewindows.com/internet-connection-sharing-ics-configuration-in-windows-7/

    • Proposed as answer by nijoao Thursday, June 29, 2017 10:34 AM
    Thursday, June 29, 2017 10:34 AM
  • Thank you nijoao, this is very helpful!  It looks like Bill was wrong, and what TRUNoise asked about can be done!
    Saturday, July 29, 2017 10:21 AM
  • Okay, I've now tested this and it does work, in 64-bit Win10 Home Anniversary Edition.

    Control Panel\All Control Panel Items\Network and Sharing Center.
    Click on the Internet connection that you want to share with another NIC.

    Click Properties.
    Click the Sharing tab.
    Then under "Home networking connection" select the other NIC (the one not connected to the Internet).
    Then check the "Allow other network users to connect..." box.
    Then click on Settings.
    Then you can configure the ports to forward: the incoming port number(s), the outgoing port number(s), the target IP address (probably 192.168.137.222 or similar), and whether to forward TCP or UDP.

    It works great!

    Time-Warner / Spectrum has been down for 21 hours here today, so I'm running my whole LAN, including my Linux-based web server, off a friend's WiFi connection, forwarded via ICS to my router. Access to my server goes through three (3) layers of NAT, but it works!


    • Edited by BurtonSys Saturday, July 29, 2017 9:01 PM
    • Proposed as answer by BurtonSys Saturday, July 29, 2017 9:45 PM
    Saturday, July 29, 2017 6:28 PM