locked
AD groups not appearing in Target Audience RRS feed

  • Question

  • Hi

    I cannot get Sharepoint to pickup any of my Active Directory security groups when i use target audience - Distrubution/Security groups. I use many different AD groups fine in the rest of Sharepoint but it is totally blank in the Select Audience dialogue box. Any ideas would be appreciated

    Thanks

    Tuesday, November 30, 2010 11:47 AM

Answers

  • Hi,

    I think the cause of the issue is that the group is an AD group. The behavior is by design. SharePoint will not unwind AD groups for audience feature to work as this will cause performance issue.

    The workarounds are:

    1.    Directly add the user to the SharePoint group or use role provider (form based authentication) and then use this for targeting.

    2.    Create Audience through SSP admin site -->Audiences link and add a rule to get the users only from a particular AD group.

    Hope it can help you.


    Xue-Mei Chang
    • Marked as answer by Mike Walsh FIN Wednesday, December 8, 2010 6:52 AM
    Thursday, December 2, 2010 6:32 AM
    Moderator

All replies

  • Hi ACECompton,

    Do you have users in this AD group? If the AD groups are not populated with users, the AD security groups will not be displayed in the target audience people picker. As a result, you need to add at least one user to this group and create a new profile import and running stsadm –o sync command.

    Hope it will help you


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Wednesday, December 1, 2010 11:50 AM
    Moderator
  • Hi,

    I think the cause of the issue is that the group is an AD group. The behavior is by design. SharePoint will not unwind AD groups for audience feature to work as this will cause performance issue.

    The workarounds are:

    1.    Directly add the user to the SharePoint group or use role provider (form based authentication) and then use this for targeting.

    2.    Create Audience through SSP admin site -->Audiences link and add a rule to get the users only from a particular AD group.

    Hope it can help you.


    Xue-Mei Chang
    • Marked as answer by Mike Walsh FIN Wednesday, December 8, 2010 6:52 AM
    Thursday, December 2, 2010 6:32 AM
    Moderator
  • I just ran into this issue.  I created the audience and tried to add (Add Audience Rule UI) the security group: domain\GroupA  ... and it would not find GroupA.

    My AD group structure:

    domain\GroupA has

    • domain\user1
    • group: domain\GroupA1

     

    domain\GroupA1 has

    • domain\user2

     

    Being in central admin I tried to test the standard people picker. So I did Site Actions > Site Permissions > Grant Permissions and proceeded to use the people picker to add my GroupA and it found it fine.  I went back to the people picker in the Add Audience Rule UI; still couldn't find it.

    I ended up doing a profile import and recompiled all of my audiences and eventually the people picker in the Add Audience Rule UI found my groups.

     

    --

    Ken

    Wednesday, February 9, 2011 11:33 PM