locked
Exchange 2007, message storge dismounts, event id 9690 RRS feed

  • Question

  • Hello,

    Twice in the past few days my 1st storage group dismounts at 5AM in the morning.  I realize I've hit my space limit.  All the solutions I have found suggest to increase the database size limit in the registry.  I found my limit is already set to 500GB, this seems high.  I know how to increase the limit, but I am not sure this is best long term solution.  Is there something else I should be doing?  I am new to supporting Exchange, so if anyone can make a suggestion I would be grateful. 

    Exchange store 'First Storage Group\Mailbox Database': The logical size of this database (the logical size equals the physical size of the .edb file minus the logical free space) is 500 GB. This database size has exceeded the size limit of 500 GB.
    This database will be dismounted immediately.

    Tuesday, March 15, 2011 5:36 PM

Answers

  • You're updating this in the registry, right?  And you're running Exchange 2007 Enterprise Edition, right?  You have two choices, increase the limit (you can make it unlimited by deleting the registry value, which will only cause you problems if you hit the volume capacity) or get your users to delete content.  That's about it unless you have an archival system.

    Are you sure you can back up and restore a 500GB database within your SLA?  You might consider creating another mailbox database and some of the mailboxes to it.  Better, you could create five new mailbox databases, move 1/5 of the mailboxes to each, dismount the first database, delete the EDB file, then mount the database again and you'll have a nice, clean, empty, new, small database.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    • Proposed as answer by Ed CrowleyMVP Friday, March 18, 2011 5:06 PM
    • Marked as answer by Gavin-Zhang Monday, March 28, 2011 6:26 AM
    Tuesday, March 15, 2011 7:28 PM
  • Hi  jlilliepad

    Above gave some good suggestion, any update for your issue.
    Some other information for you:
    http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=6.5.7638.0&EvtID=9690&EvtSrc=MSExchangeIS+Mailbox+Store

    Regards!
    Gavin
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Gavin-Zhang Monday, March 28, 2011 6:26 AM
    Friday, March 18, 2011 9:13 AM

All replies

  • You're updating this in the registry, right?  And you're running Exchange 2007 Enterprise Edition, right?  You have two choices, increase the limit (you can make it unlimited by deleting the registry value, which will only cause you problems if you hit the volume capacity) or get your users to delete content.  That's about it unless you have an archival system.

    Are you sure you can back up and restore a 500GB database within your SLA?  You might consider creating another mailbox database and some of the mailboxes to it.  Better, you could create five new mailbox databases, move 1/5 of the mailboxes to each, dismount the first database, delete the EDB file, then mount the database again and you'll have a nice, clean, empty, new, small database.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    • Proposed as answer by Ed CrowleyMVP Friday, March 18, 2011 5:06 PM
    • Marked as answer by Gavin-Zhang Monday, March 28, 2011 6:26 AM
    Tuesday, March 15, 2011 7:28 PM
  • Hi  jlilliepad

    Above gave some good suggestion, any update for your issue.
    Some other information for you:
    http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=6.5.7638.0&EvtID=9690&EvtSrc=MSExchangeIS+Mailbox+Store

    Regards!
    Gavin
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Gavin-Zhang Monday, March 28, 2011 6:26 AM
    Friday, March 18, 2011 9:13 AM
  • Agree with Ed, rather than making any change in Registry, increase the limit to Unlimited which will save you with lots of headache
    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    Friday, March 18, 2011 11:55 AM