locked
"Thumbs.db" file error RRS feed

  • Question

  • Thank goodness I didn't waste money on 8, 8.1 or any other half baked software concoction Microsoft is doling out.
    • Edited by Carey FrischMVP Monday, April 21, 2014 5:49 AM Edit title to reflect question being asked
    • Moved by Carey FrischMVP Monday, April 21, 2014 5:50 AM Relocated to appropriate forum
    Monday, April 21, 2014 4:22 AM

Answers

  • Hi,

    To enable us to help you better, you need to provide as many details as you can about the problem you are experiencing.

    I would like to know the error message.

    Thumbs.db is created when using thumbnail preview.

    Please try to clear Cache to check the result.

    1. Open Disk Cleanup.
    2. Check the Thumbnails box, and click/tap on OK.
    3. Click/tap on the Delete Files button.
    4. Disk Cleanup will now clear the thumbnail cache and close.

    If the issue persists, please disable Thumbnail Caching in Group Policy.

    1.Press Win+R, type gpedit to open Group Policy.
    2.Navigation to  User Configuration>Administrative Templates>Windows Components>File Explorer.
    3.In the right pane of File Explorer , double click/tap on Turn off caching of thumbnail pictures to edit it.And then select Enabled.
    4.Reboot the system.

    Regards,


    Kelvin Xu
    TechNet Community Support

    • Proposed as answer by kelvin_hsu Saturday, April 26, 2014 1:34 PM
    • Marked as answer by Michael_Martin Thursday, May 1, 2014 3:38 PM
    Tuesday, April 22, 2014 5:40 AM

All replies

  • Hi,

    To enable us to help you better, you need to provide as many details as you can about the problem you are experiencing.

    I would like to know the error message.

    Thumbs.db is created when using thumbnail preview.

    Please try to clear Cache to check the result.

    1. Open Disk Cleanup.
    2. Check the Thumbnails box, and click/tap on OK.
    3. Click/tap on the Delete Files button.
    4. Disk Cleanup will now clear the thumbnail cache and close.

    If the issue persists, please disable Thumbnail Caching in Group Policy.

    1.Press Win+R, type gpedit to open Group Policy.
    2.Navigation to  User Configuration>Administrative Templates>Windows Components>File Explorer.
    3.In the right pane of File Explorer , double click/tap on Turn off caching of thumbnail pictures to edit it.And then select Enabled.
    4.Reboot the system.

    Regards,


    Kelvin Xu
    TechNet Community Support

    • Proposed as answer by kelvin_hsu Saturday, April 26, 2014 1:34 PM
    • Marked as answer by Michael_Martin Thursday, May 1, 2014 3:38 PM
    Tuesday, April 22, 2014 5:40 AM
  • Hi,

    There are several days we haven't heard from you, would you please let me know whether you have tried the above suggestions I have proposed?

    Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as answer which can benefit our Community members.

    Otherwise, if there is any misunderstanding your question, please post back to clarify or the replied fail to implement what you would like to.

    Regards,


    Kelvin Xu
    TechNet Community Support

    Saturday, April 26, 2014 1:34 PM
  • There are thousands of posts with this same problem.  It was not a problem until windows 7 and has gotten massively worse with window 8 and beyond.  It is yet ANOTHER "feature" that no one wants in any way at all and is completely useless to just about everyone and significantly reduces the usability of the computer in every single way imaginable.  I should not have to edit local security policy on every computer just so that I am able to delete files correctly.  What do YOU think the correct expected behavior SHOULD be when you hit "delete"?  Do you think: MAYBE it will delete it.. if it wants to and Microsoft agrees with you.. maybe in a few hours it might delete it but that is okay.  Microsoft knows what files I want to delete on my computer better than I do!  They must want me to have this empty folder with only a thumbs.db in it or to go through a convoluted process just to delete a folder because.. why not!  It is the Microsoft way after all!"

    EDIT: Neither of the "fixes" you suggest work.  Disk clean up ONLY works for Local files and the main issue with this is Windows dumping its garbage on network folders and then not releasing it and when you try Run > GPEDIT like you suggested you get "Windows cannot find gpedit".  Bravo.  Bravo.  

    EDIT: Confirmed.  Enabling the GPO setting does nothing.  Thumbs.db files are still generated.  The thumbs files are still hidden system files that can't be deleted due to a hidden process that has them open and locked that can't be stopped, removed, or fixed.  Why am I not surprised.



    Tuesday, December 30, 2014 7:41 PM
  • Oh, and once you are done resetting all your GPOs and modifying the local folders.. Guess what..  IT STILL WON"T WORK!!!  

    Why not?  Because Microsoft has flagged the file as both a SYSTEM and a Hidden file.  So even after you have done everything above (assuming you use the correct command lines and don't copy and paste from those instructions) it STILL won't detete the file because some process (which doesn't exists it appears as the file doesn't appear as OPEN anywhere at all in the system including under OPEN FILES where it SHOULD be displayed).  So after you do all the bullshit above you THEN have to go to every single Thumbs.db file and go to properties and then deselect HIDDEN and SYSTEM or your scripts will not be able to deal with this crap.  Now repeat that several hundred thousand times until you have repaired all the damage that microsoft has done to your remote file systems.

    Once you have done that.. well it is still a crap shoot if it will delete the file or not.  Why would microsoft leave in something that is so obviously not wanted, not needed, breaks their standards, and breaks people systems?  Does Microsoft not have ANY respect for users of the product?

    Tuesday, December 30, 2014 8:33 PM
  • Please explain this:  

    Microsoft says enabling this will prevent the Thumbs.db problem.  REALLY?

    Tuesday, December 30, 2014 8:43 PM
  • The only way I have been able to accomplish deleting the thumb.db file on a shared network drive from a computer that I do not have admin access on 

    Rename thumbs.db to thumbs.jpg

    answer yes you want to rename

    and delete

    Answer hell yes you want to permanently delete this file

    Answer yes you want to delete this system file and 

    voila!

    Wednesday, August 15, 2018 10:35 PM