locked
64 bit Windows 7, 32 bit IE 9 user unable to see MOSS SP 2007 doc library in explorer view RRS feed

  • Question

  • Our farm is a 32 bit Win 2003, MOSS SP 2007 service pack 3 (with april 2012 cumulative upgrade) single server (sql server 2005 32 bit database on separate machine).

    At least one user with a problem has Win 7 64 bit desktop, Office 2010 32 bit, IE 9 32 bit, SharePoint Designer 2010 AND 2007 (which was installed after the others) <-- That's me!

    When I go to a sharepoint site on my farm, and in a doc library I select View: Explorer, I get a blank page, no windows explorer opening up, no error messages on the screen. I do not have access to desktop log files.

    If I select Actions > Open with Windows Explorer , after 1-3 minutes, the Windows Explorer window opens with the folders and files expected.

    Some co-workers have an almost instantly appearing Windows explorer when selecting EITHER the View: Explorer or the Open with Windows Explorer.

    Our machines should be similarly configured - with the exception of the recently installed SharePoint Designer 2007.

    I have recommended a run of the office diagnostics and the possibility of uninstalling and re-installing SharePoint designer 2010 to the desktop admins. They are researching the problem as we speak.

    We have a few other users that report this problem. In their case, they do NOT have SPD 2007 installed. As a SP 2007 admin, I am trying to identify additional courses of action that we might take to help resolve these issues.

    The users will appreciate any help you might be able to provide.

    Monday, January 7, 2013 8:32 PM

All replies

  • Hi,

    Do they have the WebClient Service enabled on their Desktops? The WebClient enables WebDAV and Windows-based programs to create, access, and modify Internet-based files. If this service is stopped, these functions will not be available. If this service is disabled, any services that explicitly depend on it will fail to start. The Users you have SPD also have FPRPC (FrontPage RPC) and if I remember SPD enables the WebClient Service as well... Please let me know if the WebClient Service is running... Also, check your Provider order settings of your Network Adapters got to >  Control Panel\Network and Internet\Network Connections > Clieck Advanced > then Advanced Settings > Tab Provider Order.. It should be Windows Networks on top, then WebClient Second...

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    Tuesday, January 8, 2013 2:04 PM
  • Thank you for your ideas.The webclient service is enabled and started on the desktop.

    I am one of the users with SPD, and I do not have a FPRPC service in my desktop service list.

    As
    for the network adapters, when I go to control panel on Win 7, I see a
    network and sharing center, ,not network and internet. When I go to
    network and sharing, there is a  link that when clicked goes to "network
    connections". Inside that, there is only 1 item, labeled local area
    connection.

    There is an advanced menu drop down, however, I don't have privs
    to look at Advanced > Advanced Settings and the other items on th
    emenu do not make reference to tab provider order.

    I will ask the admins about this latter item.

    Thank you once again for your help.

    Tuesday, January 8, 2013 4:18 PM
  • So a couple of pieces of information to update this thread.

    1. A support person had me change my IE9 LAN connection to turn off automatic detection, and now the delay is gone for the Open with Windows Explorer action

    2. The original user corrected my misconception of their desktop. The description I provided was of my desktop and since I was having the same problem, I assumed the original user also had that configuration.

    However, the now stranger part of this thread is that the original user is using XP and IE7, but is using Office 2010. They do not have Designer installed at all.

    So they are using a 32 bit OS, 32 bit browser, 32 bit Office accessing MOSS 2007 and still not getting an explorer view in their document libraries.

    I have requested to stop by and look at their desktop to determine whether their WebServices service is running.

    Tuesday, January 8, 2013 5:09 PM
  • Hi,

    So if I understand It works for most folks but not for a couple of users. Please provide the URL is it an FQDN are you on Port 80?

    -Ivan 


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.


    Tuesday, January 8, 2013 6:38 PM
  • 1. Yes, the Explorer view appears to work for most folk that I have
    asked (so far, a handful, but if this were happening wider scale, I
    would be flooded with problem tickets).

    2. Our small farm has a
    farm name (similar to http://myfarm ) that runs on a specific server
    (myserver). We do use port 80. We do not use proxies. We do not,
    generally, use FQDN.

    Some users for whatever reason, write their URLs http://myserver ,
    while http://myfarm is what I keep trying to teach the users to use. 
    Probably this one quirk causes more headaches than any other.

    Tomorrow,
    when my user is available for me to visit at the desktop, I am going to
    check the URL being used, as well as the services running on her
    desktop.

    Tuesday, January 8, 2013 7:24 PM
  • Hi,

    Yes if the users are using different DNS Names to login to the WebApp then have you added the additional Names AAM (Alternate Access Mapping)?

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    Sunday, January 13, 2013 3:50 AM
  • we do have various alternate access mappings defined - alias portal names, server names as well as FQDN forms for both. There is also aams for central admin and the 3rd party admin tool.

    When I got with the user and checked their desktop, they were using the portal name (the non-FQDN) as I would want them to. I confirmed their IE7/XP system was not able to get the View: Explorer to work. I was also able to confirm that using the Actions > Open with Windows Explorer did work and recommended that as a work around.

    We still have both XP and Win7 desktops, however, that cannot see explorer view simply by choosing that sharepoint view.

    Monday, January 14, 2013 4:16 PM