none
App-V Client going offline, error code 4505CD-2460590A-40000193 RRS feed

  • Question

  • When i am in disconnected mode and i try to launch an application, i get always an error stating that the application couldn't be started.

    The error message is in german:

    "Application Virtualization Client konnte für die Ausführung des angeforderten Vorgangs erforderliche Daten nicht streamen. Stellen Sie sicher, dass Sie eine Verbindung mit Application Virtualization Server herstellen können, und wiederholen Sie dann den Vorgang. Wenn das Problem weiterhin auftritt, berichten Sie den folgenden Fehlercode an Ihren Systemadministrator.

    Fehlercode: 4505CD-2460590A-40000193"

    It means that the App-V client could not stream required data and that i need to make a connection to the App-V Server.

    But: the application is 100% loaded

    Any suggestions?
    • Moved by Mathias Schiffer Tuesday, May 19, 2009 7:17 AM English Language Post (From:Virtualisierung)
    • Moved by John Paul Cook Wednesday, May 20, 2009 2:04 AM Not a Hyper-V question, belongs in App-V Forum (From:Hyper-V)
    Tuesday, May 19, 2009 6:41 AM

Answers

  • Hello,

    There is an option under a custom installation wether or not the user has to be authorized if the application is cached or not.

    This is copied from the online documentation;

    RequireAuthorizationIfCached

    DWORD

    Default=1

    Indicates that authorization is always required, whether or not an application is already in cache. Possible values:

    0=False: Always try to connect to the server. If a connection to the server cannot be established, the client still allows the user to launch an application that has previously been loaded into cache.

    1=True (default): Application always must be authorized at startup. For RTSP streamed applications, the user authorization token is sent to the server for authorization. For file-based applications, file ACLs control whether a user may access the application.

    Applied the next time an application is started.


    /Znack
    • Proposed as answer by znack Wednesday, May 20, 2009 1:56 PM
    • Marked as answer by Ma.Schmidt Monday, May 25, 2009 5:34 AM
    Wednesday, May 20, 2009 9:39 AM

All replies

  • Hello,

    There is an option under a custom installation wether or not the user has to be authorized if the application is cached or not.

    This is copied from the online documentation;

    RequireAuthorizationIfCached

    DWORD

    Default=1

    Indicates that authorization is always required, whether or not an application is already in cache. Possible values:

    0=False: Always try to connect to the server. If a connection to the server cannot be established, the client still allows the user to launch an application that has previously been loaded into cache.

    1=True (default): Application always must be authorized at startup. For RTSP streamed applications, the user authorization token is sent to the server for authorization. For file-based applications, file ACLs control whether a user may access the application.

    Applied the next time an application is started.


    /Znack
    • Proposed as answer by znack Wednesday, May 20, 2009 1:56 PM
    • Marked as answer by Ma.Schmidt Monday, May 25, 2009 5:34 AM
    Wednesday, May 20, 2009 9:39 AM
  • This setting was already been seup with DWORD = 0 in our setup but we are still receiving this error with major frequency and is causing a major issue. We are not using RTSP but HTTP so authorization should not be an issue. So it is really strange that we are receiving this problem. Hope you or anyone can assist us with this issue!

    Monday, July 20, 2009 6:24 AM
  • Hello,

    If this is set to 0 and the client has restarted - I am assuming you get this because the client needs to stream something and it can't contact the server.

    Check your logs and see what they say.

    /Znack
    Monday, July 20, 2009 6:28 AM
  • The initial installation has already set this option so the server was started with the setting set to 0. The strangest thing is that it can happen with one person on a specific terminal server and no one else on that server experiences that problem. It also occurs only with one sequence for that person and not with the other sequences. For example Person A can start adobe reader but not Office 2003 because he receives this error 193. Person B on the same server can start Adobe Reader and also can start Office 2003 without any issues. We also have illiminated our Network Load Balancing setup to see if this could be the issue but this didn't help because the error still occurs.

    The log for today is presenting the following detailed error description:

    [07/13/2009 10:15:07:215 AMGR WRN] {tid=3448}
    Attempting Transport Connection
    URL: HTTP://APPVSRE.DLL.CORP:80/Content/off/Off_2003.V2/Off.sft
    Error: 2460590A-40000193


    [07/13/2009 10:15:07:230 JGSW ERR] {hap=4CA:app=Microsoft Office Outlook 2003 11.0.8217.0a:tid=3D74:usr=erik}
    The Application Virtualization Client could not connect to stream URL 'HTTP://APPVSRE.DLL.CORP:80/Content/off/Off_2003.V2/Off.sft' (rc 2460590A-40000193, original rc 2460590A-40000193).


    [07/13/2009 10:15:07:246 SWAP ERR] {hap=4CA:app=Microsoft Office Outlook 2003 11.0.8217.0a:tid=3D74:usr=erik}
    The client was unable to connect to an Application Virtualization Server (rc 2460590A-40000193)

    Thank you for your help!

    Monday, July 20, 2009 8:53 AM
  • Hello,

    I would try to eliminiate any type of firewall between your TS / Mgt-server.

    Now, I am really confused as you say that the "server" has this option.

    Do you mean the app-v server or the app-v client has this option?

    Not really sure what the error message actually says, but it will probably give you a hint that a user failed to authenticate for some reason. Perhaps you could monitor the incomming connections / network-traffic ?

    /znack
    Monday, July 20, 2009 8:56 AM
  • We do not have any firewall between the Terminal Server and IIS server (We do not use a VAS server)

    The Server is a terminal server with a terminal server client for APP-V. The APP-V client has the option set

    The authentication should no be an issue since we are using IIS and not a VAS server so RTSP/ RTSPS is not being used but HTTP instead.

    I know it also confuses us what the issue could be we are searching high and low but we don't seem to be getting any closer to resolving the issue. We also used the best practices for APP-V on a terminal server from MS but it did not help.
    Monday, July 20, 2009 9:15 AM
  • Hello,

    What does the IIS-logs say?
    (yeah, you do use authentication - however from an IIS-perspective...)

    /Znack
    Monday, July 20, 2009 9:27 AM
  • It says the following:

    2009-07-13 10:14:41 W3SVC1 172.27.121.135 HEAD /Content/off/Off_2003.V2/Off.sft - 80 - 172.27.121.254 App+Virt+Client/4.5.1.15580 200 0 0
    2009-07-13 10:14:41 W3SVC1 172.27.121.135 GET /Content/off/Off_2003.V2/Off.sft - 80 - 172.27.121.254 App+Virt+Client/4.5.1.15580 206 0 0
    2009-07-13 10:14:41 W3SVC1 172.27.121.135 GET /Content/off/Off_2003.V2/Off.sft - 80 - 172.27.121.254 App+Virt+Client/4.5.1.15580 206 0 0
    2009-07-13 10:14:41 W3SVC1 172.27.121.135 GET /Content/off/Off_2003.V2/Off.sft - 80 - 172.27.121.254 App+Virt+Client/4.5.1.15580 206 0 0
    2009-07-13 10:14:41 W3SVC1 172.27.121.135 GET /Content/off/Off_2003.V2/Off.sft - 80 - 172.27.121.254 App+Virt+Client/4.5.1.15580 206 0 0

    For the ISS environment only Anynomous is allowed so all people should have access without an issue. Next to this the NTFS rights are set to read and execute rights for all users.

    Monday, July 20, 2009 10:53 AM
  • Hello,

    That looks good, next step would be to review so that you have the client setup. Check all settings of the client so that they are fully compatible with the IIS.

    /Znack
    Monday, July 20, 2009 11:58 AM
  • I don't see an issue in this because all other people are able to work. So shouldn't all people then not be unable to work? we use the system variable
    %SFT_SOFTGRIDSERVER% to point to the correct server where the sequence recides. Do you know of a good client configuration manual for the TS client in combination with IIS as the streaming server? I can run by the settings to see what could be different. Also do you know where I must look for in particular to see what could be wrong?
    Monday, July 20, 2009 12:40 PM
  • Hello,

    Well, to be honest I don't see an issue either. But your having one still.

    Apart from technet / whitepapers I don't know any good guides for TS / IIS environments.

    As it seems to be an issue sometimes for some users there isn't really any perfect answer. Something is playing in and to resolve it you need to define the issue in a very narrow scope and then locate the originating problem (as with all issues).

    Since I have no idea what your setup is like, what your thoughts were behind it and how it was tested first or the possibility to verify all the settings myself I would really try to locate the "odd" behaviour and see what factors are playing into it.

    /Znack
    Monday, July 20, 2009 1:16 PM
  • Presumably you have solved this issue by now.  If so, it would be great to tell us how!  If not, perhaps I can shed some light on where to look.

    The 0A-40000193 error in hex is the equivalent of a web server issuing a (Decimal 403)  authorization error.  We see this (in the form of 0A-2000193) for a variety of reasons in the RTSP and RTSPS case that revolve around authorization issues, but for HTTP with anonomous access allowed this would be unusual.

    The bottom line is that something (hopefully the IIS server) must have returned a 403 error on port 80 for the client for it to to report 0A-40000193.  Quite possibly your IIS log reporting was taken when valid requests happened.  Otherwise, perhaps there is something in your environment causing the client to end up talking to another device listening on port 80.  Naming and IP issues would be likely.   


    Tim Mangan MVP for App-V and Citrix CTP
    Monday, October 4, 2010 10:54 PM
    Moderator