locked
.NET 1.1 App Problem RRS feed

  • Question

  • Hello,

    I try to sequence a network app (located in a network share) mainly using .NET 1.1 SP1 on the desktop to run. No any installation required, just the .NET.

    The only thing you need is to set a special security level in .NET settings with the following command line :

    "%SystemRoot%\Microsoft.NET\Framework\v1.1.4322\caspol.exe -q -chggroup 1.2 FullTrust"

    Once done the app will run from the network "\\SERVER\AppPath\App.exe" then it works.

    When I try to launch that command into a bubble (with sequencer 4.6 SP1) the application will crash (the .NET debugging services) with the following error :

    Ok. So I've tried to install the .NET 1.1 SP1 in the bubble while sequencing. But the sequencer says the .NET 1.1 SP1 is using COM+ functions that are not supported by App-V. Anyway, even with .NET 1.1 into the bubble the application crashes the same way.

    That's a problem for us because the application will generate some exports that need a small application and a special version of Office (XP) so I wanted to add them into the bubble to virtualize them. (the application itself has no need for virtualization, except for those "plug-ins").

    Is there any solution to debug the app ? Why the app is not able to run even in an "empty" bubble ? THe VFS and virtual registry are all empty it should be using the local system so I don't understand...

    Thanks for any help !


    Friday, April 29, 2011 3:00 PM

Answers

All replies

  • What client operating system are you using?

    Have you seen this knowledgebase article? http://support.microsoft.com/kb/959524


    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Friday, April 29, 2011 3:13 PM
    Moderator
  • Hello,

    It's Windows XP SP3 (client and sequencer) with latest critical updates and the .NET 1.1 SP1.

    Both .NET have french language pack. Don't know if that matter.

    The problem happens on the sequencing machine, and on my 2 test client also. 1 test client is the exact model of a standard PC in my company (GPO, apps etc), the other is a more "clean" machine for testing.

    Thel .NET 1.1 SP1 is installed locally on the sequencer before attempting to sequence the application.

    When I  run the application from the network path on the sequencer (not sequencing, just testing), it works perfectly.

    When I'm in the monitoring phase with the App-V 4.6 SP1 and try to launch the application, it crash. Launching the application in the virtual environnement will just not work.


    The virtual environnement is empty, I just need to reach the .NET layer. Nothing is installed locally, and the app is working on the sequencer when I stop monitoring....

    Maybe something that is not supported, the application tries to synchronize the client date and time with it's own server time before launching. Maybe this action is not well coded so the App-V doesnt support it....


    Sunday, May 1, 2011 12:50 AM
  • Hello,

    have you tried running it from the local machine - as opposed to from the network path? 
    /Znack
    Sunday, May 1, 2011 8:15 PM
  • Sorry. Posted that the problem was solved.

    Actually I've gone to fast to the happy state where you think you have solved your problem :)

    Launching "RunAs" in the bubble is working, but actually your are "jumping" outside the bubble !

    Your applicaiton will not run in the virtual environnement ! So it's working, but modules I've installed in the bubble are not available for my .EXE.

    .... I'll have to look again.

    • Marked as answer by Sergetov Tuesday, May 3, 2011 7:02 PM
    • Unmarked as answer by Sergetov Wednesday, May 4, 2011 9:09 AM
    Tuesday, May 3, 2011 7:02 PM
  • Have you tired enabling the LOCAL_INTERACTION_ALLOWED tag?

    http://blogs.technet.com/b/appv/archive/2007/09/20/a-look-under-the-covers-the-local-interaction-allowed-tag.aspx


    Steve Thomas, SSEE, Microsoft
    App-V/MED-V/SCVMM/SCCM/AppCompat
    http://madvirtualizer.wordpress.com/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”
    Wednesday, May 4, 2011 7:12 PM
  • Yes I've tried that and didnt work. :(
    Wednesday, May 25, 2011 10:02 AM
  • Sunday, June 12, 2011 10:03 PM