locked
2 domains 1 Exchange 2010 server - Out of office issue RRS feed

  • Question

  • I have a 2 domains and 1 exchange server. When users log into domain A (where the exchange server resides) Out of office for Outlook 2010 has no issue. However, when I launch a citrix session into domain B and launch Outlook the out of office assistance says "your automatic reply settings cannot be displayed because the server is currently unavailable.

    I have domain A setup as a secondary DNS zone so I can see all records.

    Thursday, August 30, 2012 1:52 PM

Answers

  • yes, 100% positive on 2 way trust. here is how I resolved it. I changed DNS to point to domainA (primary)on the citrix xen app servers that are in domainB. Then went into IE, connections, LAN settings added the name of the Exchange server under exceptions then unchecked proxy and then autodiscover worked
    • Marked as answer by jwestrock Tuesday, September 4, 2012 7:41 PM
    Tuesday, September 4, 2012 7:41 PM

All replies

  • Hi,

    That error message is often caused by autodiscover issues.

    Have you created an autodiscover DNS record that can be resolved in domain B?

    Leif

    Thursday, August 30, 2012 2:05 PM
  • I can ping the  A record autodiscover.domainA.local is there something  else that needs to be done in the new domain (domain B)?

    Thursday, August 30, 2012 2:46 PM
  • This is what I have found. If I login to domain B with the user account and launch outlook it tries to configure the mailbox (since this is the 1st time logging into domain b) and autodiscover doesnt populate the entries. However, when I login to domain A then do crtl + c and click on outlook and run the test email auto-config I noticed it populates the login name with joe.user@domainB.com  and states auto config unable to determine your setttings but when I type in the correct user info for domain A juser@domainA.com it populates and life is good

    Thursday, August 30, 2012 7:18 PM
  • hi,

    >>>I have a 2 domains and 1 exchange server.

    Two domains two forest, is it right?

    If i am right , i think you should export the scp value from forest A and then import the value into the forest B.

    How to export the scp please see this link:http://technet.microsoft.com/en-us/library/aa996849.aspx

    you also can see the autodiscover whiter paper:http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx

    If i am wrong, please feel free to tell me. And tell me your actual topology.

    hope can help you

    thanks,


    CastinLu

    TechNet Community Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com



    • Edited by Castinlu Friday, August 31, 2012 5:14 AM
    Friday, August 31, 2012 2:57 AM
  • Yes two forests. I have trusts setup between the domains. domain A has the exchange server and when users login into domainA no issues. I have 4 citrix servers in domain B. When users login in to their citrix sessions (the servers are registered  in domain B) they login with domain A credentials however OOF wont work. How do I get autodiscover to work in both domain A and domain B. I am researching the above documents but a little unsure on export then import. I am using exchange 2010 standard and my domain level is win2k8 r2
    Friday, August 31, 2012 1:35 PM
  • [PS] C:\Windows\system32>Export-AutoDiscoverConfig -TargetForestDomainController domainB.local -MultipleExchangeDeployments $true

    WARNING: When you use the Export-AutoDiscoverConfig cmdlet to configure Autodiscover between forests, the account

    specified in TargetForestCredential needs to be a member of the Enterprise Administrators group in the target forest.

    Friday, August 31, 2012 9:10 PM
  • hi,

    >>>the account specified in TargetForestCredential needs to be a member of the Enterprise Administrators group in the target forest.

    Have you try to add the account into the Enterprise Administrators group in the target forest.

    I recommend that you should follow the white paper that i post above.

    Please see:How to Configure the Autodiscover Service When You Use Multiple Forests in the white paper .

    hope can help you

    thanks,


    CastinLu

    TechNet Community Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    • Edited by Castinlu Monday, September 3, 2012 3:11 AM
    Monday, September 3, 2012 3:11 AM
  • I cannot add domainA admin account to the enterprise admis group

    Tuesday, September 4, 2012 1:41 PM
  • From source forest open aduc, find domain admins, member of tab and add targetdomain\administrators. Then make sure targetdomain\administrators is in the enterprise admins of the targetdomain.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com


    Tuesday, September 4, 2012 2:49 PM
  • the issue is I cannot see domainA from domainB when trying to add to domain admins or enterprise admins group. I can see domainB when adding a domain local security group but cannot add a domain local to a universal or global group
    Tuesday, September 4, 2012 3:47 PM
  • You need to do it from domainA side not from the domainB side.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Tuesday, September 4, 2012 3:52 PM
  • Im in aduc in domainA. click on domain admins, then members tab then locations and I cannot see domainB. What am I missing?

    Tuesday, September 4, 2012 4:03 PM
  • Are you able to Ping autodiscover.domainb.com?

    If not then check your DNS settings as you will need to have this entry to point to the exchange CAS server.


    Also verify whether the trust validation is happening properly and the name resolution across forest is happening properly.
    • Edited by Mits_J9 Tuesday, September 4, 2012 4:20 PM
    Tuesday, September 4, 2012 4:18 PM
  • yes, I can ping the FQDN for autodiscover and I have a 2 way trust forest wide authentication and validated it is functioning
    Tuesday, September 4, 2012 4:25 PM
  • In your few earlier post you mentioned you can ping autodiscover.domaina.com.

    So you mean you can ping autodiscover.domainb.com as well.

    Are you using public folders?

    If yes then check on the mailbox database containing the user mailbox whether the public folder is selected for that database.

    Is it happening through OWA as well?

    try bypassing *.domainb.com or *.domainb.local

    Also refer

    http://social.technet.microsoft.com/Forums/en-AU/exchangesvrgeneral/thread/e27c4dcc-f19e-496b-972e-de347c00df21

    http://thoughts.stuart-edwards.info/index.php/sysadmin/exchange-2010/your-automatic-reply-settings-cannot-be-displayed-because-the-server-is-currently-unavailable

    • Proposed as answer by Mits_J9 Wednesday, September 5, 2012 3:06 AM
    Tuesday, September 4, 2012 4:50 PM
  • Im in aduc in domainA. click on domain admins, then members tab then locations and I cannot see domainB.

    Are you sure you have a 2 way trust? What about if you just manually enter domainB\administrators


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Tuesday, September 4, 2012 5:15 PM
  • yes, 100% positive on 2 way trust. here is how I resolved it. I changed DNS to point to domainA (primary)on the citrix xen app servers that are in domainB. Then went into IE, connections, LAN settings added the name of the Exchange server under exceptions then unchecked proxy and then autodiscover worked
    • Marked as answer by jwestrock Tuesday, September 4, 2012 7:41 PM
    Tuesday, September 4, 2012 7:41 PM