none
Error on Exchange 2003 uninstall. RRS feed

  • Question

  • Greetings,

    I have been trying to uninstall Exchange 2003 on of our front-end servers with no success. I have searched but I have not found an answer for this error. There used to be an issue with me having an acount there but I have removed it. I reinstalled the SP2 and tried different methods but I still get the same errors. Our environment consists on 2 Front-End servers on a DMZ and 2 back-end servers.

    I would appreciate it if anyone has a clue on what to do. If I cannot solve it in the next few days I will be forced to remove this server manually and would like to avoid this if possible.

    Thank you.

    Tuesday, August 27, 2013 4:36 PM

Answers

  • Perhaps what you're seeing is one of the reasons it's never been supported to place an Exchange server in a DMZ except for the Edge role in later versions.

    Actually, uninstalling Exchange 2003 often doesn't remove it from the organization.  What I would do is first shut down and wipe the server.  Then right-click the server object in the Exchange System Manager and remove it.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Wednesday, August 28, 2013 3:53 AM
    Moderator

All replies

  • Perhaps what you're seeing is one of the reasons it's never been supported to place an Exchange server in a DMZ except for the Edge role in later versions.

    Actually, uninstalling Exchange 2003 often doesn't remove it from the organization.  What I would do is first shut down and wipe the server.  Then right-click the server object in the Exchange System Manager and remove it.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Wednesday, August 28, 2013 3:53 AM
    Moderator
  • Hi,

    This problem should occur if a user account in the AD directory service has the affected mailbox server listed on the msExchHomeServer attribute.

     

    To resolve this problem, please remove the affected mailbox server entry from the mxExchHomeServer attributes in AD.

     

    More details in the following KB :

    Error message when you try to remove Exchange Server from a mailbox server that no longer hosts mailboxes: "One or more users currently use a mailbox store on this server"

    http://support.microsoft.com/kb/924170

     

    Hope it is helpful

     

    Thanks

    Mavis

    Wednesday, August 28, 2013 10:02 AM
    Moderator
  • If that were the case, in trying to remove the server using the Exchange System Manager, it would tell you that.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, August 28, 2013 3:33 PM
    Moderator
  • Yes I feared I may have to do this. Already did once after one server died with no recovery option.

    Do you think it'd work if i allow all access (ports and all) from that server to our back-end server or just not bother with this any more?

    Thursday, August 29, 2013 7:49 PM
  • Thank you. Yes, I had this error before and that was resolved. The issue is now a bit different as there's no such message anymore.
    Thursday, August 29, 2013 7:50 PM