none
Exchange2013: ms-Exch-SMTP-Accept-Any-Sender not working with FrontendTransport

    Question

  • Hi everybody,

    we are implementing a MX Exchange 2013 (CU 2) as the first Exchange server in the organization.

    A ReceiveConnector for connections from our LAN network should allow authenticated users to send mails as any sender string. The solution I found here and elsewhere on the net seems to be simple:

    Add-ADPermission -identity smtp-lan-relay -user "nt-autorität\anonymous-anmeldung" -extendedrights "ms-Exch-SMTP-Accept-Any-Sender"
    Add-ADPermission -identity smtp-lan-relay -user "nt-autorität\anonymous-anmeldung" -extendedrights "ms-Exch-SMTP-Accept-Authoritative-Domain-Sender"
    

    Unfortunately it is not working with FrontendTransports!
    If I delete the connector and set it up as HubTransport it works!

    Now my questions:

    • is that a known issue / bug or a wanted behaviour?
    • is there any disadvantage if I am running the connector as Hubtransport instead of FrontendTransport (as it should be)?

    Thanks a lot for your help!

    Thursday, July 11, 2013 2:24 PM

Answers

All replies

  • Hi

    It might be a known issue and I Found a similar thread

    http://social.technet.microsoft.com/Forums/exchange/en-US/44b67f45-25cb-4496-b8e0-c94d55c98281/authentication-changes-2013-on-receive-connector

    It used the same workaround as yours

    To create a new receive connector and define it as a Hub Transport and not a Front-End Transport.

    I dont think there will be any disadvantage.

    Cheers


    Zi Feng
    TechNet Community Support

    • Marked as answer by blindzero Tuesday, July 16, 2013 6:58 AM
    Friday, July 12, 2013 6:41 AM
    Moderator
  • Hi Zi Feng,

    thanks for your confirmation...known issues sounds as "bug" that should / will be fixed in the future?
    So I will change all my connectors to hub-transport in the meantime.

    What I dont understand: if there is no disadvantage for me to set it as hub-transport I dont get the reason why there are different transport-roles at all...?!?

    Thanks,

    Matthias

    Friday, July 12, 2013 8:08 AM
  • Not sure it will be fixed or not, please wait for the released notes.

    In my point of view, change to hub transport is just a workaround due to this known issue, and it will take any bad effect, But these two settings should be different. 

    Friday, July 12, 2013 8:41 AM
  • ... and it will take any bad effect, But these two settings should be different. 

    Garen,

    did you men will not take and bad effectt?

    Because if there are bad effect, I would maybe not implement the workaround ;-)

    Thanks,

    Matthias

    Friday, July 12, 2013 8:43 AM
  • Sorry, my mistake. I mean it will not.
    Tuesday, July 16, 2013 2:45 AM