locked
Microsoft Edge Chromium issues RRS feed

  • Question

  • Windows 10Pro build 2004

    Edge: Version 83.0.478.58 (Official build) (64-bit)

    I installed new edge and it worked fine for a while.

    Here are my issues:

    1. Extremely slow open of "new window",,~ 3 minutes
    2. Lost "remember" of my website logon/passwords. Since I have many, I now have to reenter each one and hope it remembers. Why did this happen from migration from Edge which had all the saved logon data
    3. Why, again, is there no  "sort by name" in favorites. I have many folders in favorites and was well sorted in Edge. It is a mess now. We waited forever to get sort  by in edge, why did it not come over to Chromium
    4. If you open a PDF in a tab, e.g. bank statement and go to print, it first only shows Aave as PDF in printer drop down list. Until the print preview is opened can you get the full printer drop down list. Then when you select the new printer, it has to regenerate the document preview. A real time waster since I have a default printer assigned already. Only on PDF tabs.

    I thought I'd list these for review


    John Lenz

    Monday, July 6, 2020 8:11 PM

All replies

  • Other than (3) you seem to be using a different version of Edge Chromium to mine.

    Monday, July 6, 2020 8:28 PM
  • Hi,

    In regard to your issue of'Microsoft Edge Chromium',here's my suggestions:
    1. Slow open of new window:You can refer to the following link to make microsoft edge faster
    Microsoft Edge Running Slow After Windows 10 update version 2004

    2. Lost "remember" of website passwords:You can refer to the following link to use credential manager to manage your wesite credentials.
    How to view, edit and delete saved passwords on Edge

    3. No  "sort by name" in favorites seems  to be a known issue in this version of edge in win10.

    Hope my answer will help you, thanks!


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Gloria Gu Monday, July 13, 2020 2:14 AM
    Tuesday, July 7, 2020 8:41 AM
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 9, 2020 7:45 AM
  • Hi,
    Just want to confirm the current situations. Please feel free to let us know if you need further assistance.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 13, 2020 2:14 AM
  • I reported a false positive on the open timing. What I just noticed is that my reply never made it out of teh new Edge session.

    I did clear the cache and change days to remember from 20 to 5. Edge still is horribly slow; but only on 2 of my Windows 10 Pro domain systems.

    I have a total of 10 WIndows10 Pro Domain systems in my house (home business). Unfortunately, the 2 I use the most are the worst performers. Each is on a different ISP and all have excellent download speeds, >100 MB/sec.

    Examples...

    4 minutes to execute "new Window" to open and and operating

    Very slow movement in my Chase account site, yet on non-affected systems, 1-2 seconds response.

    While trying to open an AMEX site to pay a credit card bill, it went totally white (non-responsive). I let run for 10 minutes with no clearing. I had to task manager it to close. I opened Amex site on other system and process payment with no delays.

    The 2 slow systems have Norton endpoint client, office 2013 as primary software that is active.

    I have run virus sweep, malware bytes and reg clean. Still slow.

    Any ideas as to what to lok for in these 2 systems??

    Thanks

     

    John Lenz

    Monday, July 13, 2020 4:37 PM
  • Sort by name is not an issue in this version of Edge...

    Open the Favorites management and you just need to right-click on the right of the favorites 

    Gérald

    Monday, July 13, 2020 8:20 PM
  • Thanks for showing me the sort!

    Any ideas' on performance?


    John Lenz

    Tuesday, July 14, 2020 2:54 PM
  • We just started the tests in our office so can't tell right now...

    Will have a look but I already had the feeling it's hard to start... Don't know if it's our SharePoint Intranet design or not.

    For the "Sort by Name", I agree it's not where you look at first time... I had to search a bit lol


    • Edited by Gérald Mathieu Tuesday, July 14, 2020 5:29 PM Stupid kitty pressed Enter lol
    Tuesday, July 14, 2020 5:27 PM
  • "Edge running Slow" in this build does not have advanced options in APPS so no repair. I do weekly registry scan/repair. Also just ran SFC /scannow with no corruption.

    What next to check or how to "repair"


    John Lenz

    Wednesday, July 15, 2020 6:05 PM
  • Hi,
     
    Just want to confirm the current situations.
     
    Please feel free to let us know if you need further assistance.

    Best regards,
    Gloria

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 31, 2020 8:09 AM