locked
Skype for Business CU3 update breaks Elastix/Asterisk interoperability RRS feed

  • Question

  • I have a very strange problem and i need your help to solve it.
    I have a Skype for Business Server that uses Elastix as a PBX. On my Skype for Business Server i have several snom7xx and snom300 UC edition phones and on my Elastix i keep a few extensions with latest firmware snom300 (not UC) as well as some Cisco 303.

    After the latest Skype for Business update (cu3) all SNOM300 phones, either UC on Skype or normal on Elastix and Cisco phones, are receiving breaking audio when the call is coming from Elastix. The audio transmission (sending) is fine.

    If i connect a snom7xx instead, the problem goes away. I am using the exact same configurations and codecs.

    I know that the problem was caused by the Skype for Business CU3 update but why hasn't affected the snom7xx phones? Is there something i can do (a setting maybe) to fix the breaking incoming audio on snom300 and cisco 303?

    I have had the same configuration on elastix for years now without any issues (OCS,Lync all versions and SFB before cu3). I have tried elastix 2.4 and 4.0 but the issue still remains.
    Thursday, October 13, 2016 8:31 AM

Answers

  • Hi MichaelCentaur,

    Thanks for your response.

    Since Skype for Business CU3 is the latest version, there may be compatibility issue with SNOM300 phones, either UC on Skype or normal on Elastix and Cisco phones, we will collect the feedback and then we will improve our product as soon as possible.

    Hope this reply helpful to you.


    Alice Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Monday, October 24, 2016 8:36 AM
    • Marked as answer by Alice-Wang Friday, October 28, 2016 9:52 AM
    Thursday, October 20, 2016 9:11 AM

All replies

  • Hi MichaelCentaur,

    Welcome to post in our forum.

    Would you please tell us did you mean that everything works fine before you updated to SFB CU3 ?

    Since there is no problem with snom7xx in your environment, based on my understanding, there is no issue with SFB server side and PBX.

    So we will give you the following tips:

    For the IP phones, please try to update the firmware to the latest and test again.

    If the issue persists, please try to reset your IP phone and test again.

    Hope this reply helpful to you.


    Alice Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 14, 2016 8:19 AM
  • Hi Alice,

    Thank you for your reply,

    Before updating the Skype for Business server to CU3 I could call from any handheld device to any other handheld device without any issues. I have SNOM300 phones with UC edition that work well with SFB and I also have SNOM300 phones without UC edition firmware that are on elastix/asterisk. After the update when I try to call skype to elastix or elastix to skype, the device on elastix cannot receive the audio correctly. If I use a SNOM710 on elastix side, I have no problem.

    I tried upgrading firmware, resetting phones etc. What I want to understand is why did this issue appear after the CU3 update? Maybe there is a setting I can change on SFB server and restore the functionality. Some kind of codec change or protocol?

    Monday, October 17, 2016 9:58 AM
  • Hi MichaelCentaur,

    Thanks for your response.

    Since Skype for Business CU3 is the latest version, there may be compatibility issue with SNOM300 phones, either UC on Skype or normal on Elastix and Cisco phones, we will collect the feedback and then we will improve our product as soon as possible.

    Hope this reply helpful to you.


    Alice Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Monday, October 24, 2016 8:36 AM
    • Marked as answer by Alice-Wang Friday, October 28, 2016 9:52 AM
    Thursday, October 20, 2016 9:11 AM