none
a few drivers are never installed RRS feed

  • Question

  • hello all,

    been battling this issue for that last two days. 

    Trying to configure MDT 2013 for Windows 8.1 deployment with USB keys. Everything is working OK as it seems except when I log on to the tablet for the first time, I see there are 4 devices under "Other Devices"  and 3 of them are "Unknown device"

    If I update the driver software for those devices using the folder "Out-of-Box Drivers" located on the USB key, they all install OK. Actually, it's a bit more confusing than the way it sounds. If I update the last device in the list, it moves automatically under the right category but one more  "Unknown device" shows up under "Other Devices". If I again update the last one in the list, it moves again to its category but then two more Unknown devices show up. All in all, there are 7 devices that require driver updating but one wouldn't know it by just looking in Device Manager in the beginning.

    Anyway, I got so desperate looking for clues that I took the PnP ID for one of the devices and searched the whole C: drive for any .log files that contain this string, ACPI\INTCCFFD. It was found in one file only, setupapi.setup.log and it's one line only:

    set: ACPI\INTCCFFD\2 -> configured [null] (ConfigFlags = 0x00000040)

    Anyone know what this might mean?

    I use Selection Profile and the setting is "Install only matching drivers from the selection profile". This is in the Preinstall phase. In Postinstall, it's the usual "Inject drivers" running ZTIDrivers.wsf

    if you need more info, i'd be happy to provide it

    thanks all

    Edit: I also tried "Install all drivers from the selection profile" and the difference is that ZTIDrivers.log shows the files as being copied to C:\Drivers but no change in Device Manager.



    • Edited by md8070 Thursday, August 14, 2014 8:01 PM
    Thursday, August 14, 2014 7:55 PM

All replies

  • We would need more information, specifically the bdd.log file that's located in C:\Windows\Temp\DeploymentLogs\ and the Hardware ID you're having issues with.  Thanks.
    Friday, August 15, 2014 2:25 PM
  • i'll have to do this from home. the company here blocks all file sharing sites

    thanks

    Friday, August 15, 2014 3:22 PM
  • Well that's also the log you're going to want to look through.  Open that log file and do a CTRL+F for the device you're having issues with and see if it either installs a driver, or reports that it cannot find a driver for device.
    Friday, August 15, 2014 3:28 PM
  • i've already looked through it

    the devices in question do not appear in this log file

    some of them have more than one HardwareID so I collected them all, 7 devices times 2 HardwareIDs (on average) and searched that file for each and every one of them

    and, as I mentioned in my first post, I even searched the whole drive for any files containing a few of these

    Friday, August 15, 2014 5:13 PM
  • Complex issue, with an even more complex answer. The question is: Is the device not being identified by MDT, or is the driver (which MDT correctly copied to c:\drivers) not getting loaded up by the OS? There is a long chain of things that need to be setup correctly for a driver to be loaded by the OS. If something breaks down, then we need to know where.

    * Look in the bdd.log file for ACPI\INTCCFFD, if not present, check the pnpenum.xml file, if still not there, ZTIDrivers may not work for you, try loading the driver as an Application package.

    * Search for where the driver package was copied down locally. I like to grep the bdd.log file for the string 'xcopy', since xcopy is used to perfrom the actual file copy of drivers down locally. If not matched, does the driver package have a reference to your PNPID "ACPI\INTCCFFD"?

    * If the correct driver was copied down, it's *still* possible that you have a driver that is *NOT* supported by the OS after all, right click on the device in the Device Manager (devmgmt.msc), click "Update Driver", and select the driver package that was copied down locally to the c:\drivers directory. If it won't install, you will need to do advanced driver install debugging with the setupapi.*.log files.

    * If you tried all of this, and it still didn't work, copy your bdd.log, drivers.xml, drivergroups.xml, selectionprofile.xml, pnpeum.xml files to a public site like onedrive and share the link here.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Friday, August 15, 2014 7:03 PM
    Moderator