locked
Storage spaces, ReFS error: No Valid Superblock, data integrity checksum error, data in filestream is corrupt RRS feed

  • Question

  • I've been using Storage spaces for many years. I have one large 50TB mirrored pool consisting of many drives across many different enclosures. 

    I recently lost all access to the pool - it shows up in disk manager as RAW file system. The drive letter still shows in explorer but it is unable to access any files. This happened after a reboot.

    I ran "refsutil salvage -D s: c:\refs -v -x" and got this:

    ReFS version: 1.2
    Boot sector checked.
    Error: No valid superblock!
    Error: Command failed.
    Error: A data integrity checksum error occurred. Data in the file stream is corrupt.

    I then tried this: refsutil salvage -QS s: c:\refs -v -x

    eFS version: 1.2
    Boot sector checked.
    Cluster Size:  65536 (0x10000).
    Cluster Count: 838857728 (0x31fff400).
    Error: Command failed.
    Error: {Corrupt Disk}
    The file system structure on the disk is corrupt and unusable.

    I looked in eventviewer and found entries "The file system detected a checksum error and was not able to correct it.", and "Volume S: is formatted as ReFS but ReFS is unable to mount it; ReFS encountered status The volume repair was not successful."

    Is there anyway to recover the data?


    dal

    Thursday, September 10, 2020 6:04 PM

All replies