none
When will be be Offline IM available for SfB on-premise

    Question

  • Hello, when is it planned to support Offline IM for Skype for Business 2015 on-premise?

    I thought I enable offline IM on our on-premise installatoin following https://support.office.com/en-us/article/Turn-on-or-off-Offline-Messages-for-admins-8967a77f-caa2-4680-aa22-8faa32c716e4?ui=en-US&rs=en-US&ad=US - while I had to learn that CsClientPolicy param "EnableOfflineIm" does not even exist :-(

    I will now install latest CU update 6.0.9319.235 from March 2016, hoping this will bring that functionalty to on-premise SfB as well.

    kind regards,

    Dieter Tontsch

    mobileX AG

    Friday, April 22, 2016 12:35 PM

All replies

  • Ok, I have installed March 2016 CU for Skype for Business. Unfortunatelly, at least this policy parameter EnableOfflineIM still does not show up. So, I assume, offline IM Support only is supposed to work with Office 365 Skype. Well, sad, because offline IM support is a feature which is supported by free skype and almost any other Instant Messaging tool since many years.

    There is a note: "Offline IMs are only available in the latest version of the Click-to-Run Skype for Business client and aren't available when an older Click-to-Run Skype for Business is used or a *.msi file was used to install the Skype for Business client. " at https://support.office.com/en-us/article/Turn-on-or-off-Offline-Messages-for-admins-8967a77f-caa2-4680-aa22-8faa32c716e4?ui=en-US&rs=en-US&ad=US

    As we run an on-premise install, some with click-to-run client, but some with local install also (because of the fact that e.g. MS Project in snot avail as click-to run as far as I know), it seems that we are not eligible to this great NEW feature.

    • Proposed as answer by Markus_95 Wednesday, August 31, 2016 6:27 AM
    Friday, April 22, 2016 1:51 PM
  • Hi,

    This feature is available for Skype for Business 2016 client, please update SFB 2016 to latest version.

    On Server side, EnableIMAutoArchiving and DisableSavingIM properties both set to True, then test if the feature appear or not.

    Best Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Monday, April 25, 2016 2:12 AM
    Moderator
  • Hi,
    yes, both, EnableIMAutoArchiving  and DisableSavingIM are set to true. And yes, the clients are 2016, more precisely it is build 16.6741.2026 - so rather new.
    But unfortunately offline IM does still not work, beside this anyoing Draft Folder fill-up described e.g. https://social.technet.microsoft.com/Forums/lync/en-US/d6efc699-d81b-4575-a3d9-dcc954856f59/outlook-draft-folder-filling-up-with-missed-conversation-messages-from-skype-for-business-2016?forum=sfbfr, nothing else happens.
    Do ou know any on-premise installation where this feature works?

    kind regards,
    Dieter Tontsch
    mobileX AG
    Monday, April 25, 2016 7:26 AM
  • Hello Dieter,

    Do you have any news about that issue?

    Best Regards!


    Robson Hasselhoff - Follow me @Robk9e

    Monday, June 06, 2016 2:24 PM
  • Unfortunately not, you?

    Dieter

    Monday, June 06, 2016 2:39 PM
  • Hi, we have it working with SFB CU4 and SFB client version 16.0.6828.1019.

    When user is offline, an email will be sent to inbox with the message. Look like missed conversation.

    This started to work after 2 latest office365 updates.

    DisableSavingIM  should be false and not true.

    EnableIMAutoArchiving  should not have any value (default)


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work


    Monday, June 06, 2016 3:00 PM
  • Hmm, CU4 we also have. My client is yet a bit older (16.0.6701.1026).

    But do you have Exchange 2010 or newer in use? I think this also is an issue, we still run on Exchange 2010 SP3 for now.

    cheers,

    Dieter

    Monday, June 06, 2016 3:20 PM
  • Hi, we are in exchange hybrid (2013 on-prem and exchange online).

    "The offline messaging feature depends on the EnableIMAutoArchiving property to be set to True. If the setting is set to False, offline messaging will not be enabled."

    It could be exchange version, but strange it has other requirement when missed conversation works?

    does missed conversation work for you?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Monday, June 06, 2016 3:38 PM
  • My case is a bit different of yours.

    Our environment is set up as Hybrid (Skype OnPremise and Exchange Online) and all clients are in the version (16.0.67.01.10.13).

    I will change the policy with values that you suggested to see what will happen.

    Thanks



    Robson Hasselhoff - Follow me @Robk9e

    Monday, June 06, 2016 7:54 PM
  • We are also using SFB on-premise and Exchange Online. Only thing not working for us in this setup is serverside conversation history does not work.

    It works if both SFB and Exchange is online or both SFB and Exchange is on-prem.

    MS support confirmed its client issue and was supposed to be patched since march, but still no go


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Tuesday, June 07, 2016 7:42 AM
  • Good news!

    After I changed the values as you suggested the offline messages began arriving.

    PS C:\Users\robso> Get-CsClientPolicy | select disableSav*,enableIM*,EnableServerCon* | fl *

    DisableSavingIM                 : False
    EnableIMAutoArchiving           :
    EnableServerConversationHistory : True

    Just would like you be aware the skype users are on premise and the users' mailbox are on exchange online.

    Thanks




    Robson Hasselhoff - Follow me @Robk9e

    Thursday, June 09, 2016 2:04 PM
  • Hi, this still does not work for me. When I send a chat to an offline user I instantly get the following message in my chat window:

    Exchange 2016 kann zurzeit keine Chatnachrichten empfangen. Der Status lautet "Nicht verfügbar" oder "Offline"

    This means translated from German: Exchange 2016 (this is chat peer name) can not receive chat messages at this time. The status is "not availale" or "offline"

    My Policy settings are:

    DisableSavingIM: False
    EnableIMAutoArchiving:
    EnableServerConversationHistory: True
    Identity: Tag:mXClientPolicy

    What kind of magic is still required to make this working? Exchange is 2016 and skype Srv. is 2015, Clients are both 16.0.6925.1018

    Dieter


    Friday, July 01, 2016 11:42 AM
  • If you want to use the Server side offline im, you have to install SFB 2015 Server CU2 and for SFB client offline im the latest SFB Client.

    The offline IM will be send through Exchange, Exchange 2010, 2013, 2016 is supported.


    regards Holger Technical Specialist UC

    Friday, July 01, 2016 2:20 PM
  • I have all these, we run Exchange 2010 SP3 and 2016 (the accounts in charge are on EX 2016), SFB 2015 CU2 (6.0.9319.235) and client Version 16.0.6925.1018, as mentioned already. This should be fine from the versioning poit of view, shouldn't it? EWS URL's are also detected properly, I suppose this is required in order to pass the offline message to Exchange, don't know... However, other Emails, mainly "Recorded Conversations", (have translated the Outlook folder name from German, don't know if this is quite correct) are working...

    If I open a chat window to a client how is offline, it shows me like "Offline 13 hours - Only Offline Chat Messages"status message - this looks fine at a first glance. But when I send a chat message it returns like "xy cannot receive chat messages right now, his status is "not available" or "offline"" (again translated from German UI).  And nothing happens, the message I send to him never arrives his Oultook inbox or something...

    What's wrong at my side?

    Cheers,

    Dieter

    Monday, July 04, 2016 6:31 AM
  • Hi,

    we have same settings, but our SFB client are on version 16.0.6729.1012.But we are using Exchange Online and SFB 2015 on prem.

    Can you run this command on your SFB server:

    get-csarchivingconfiguration

    Then provide the output?

    Are you using local store or dedicated sql server?

    As far as I know, this function only works using desktop client, not mobile client.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Monday, July 04, 2016 1:25 PM
  • We run SQL localy

    PS C:\Users\Administrator.xxxxx> get-csarchivingconfiguration


    Identity                  : Global
    EnableArchiving           : None
    EnablePurging             : False
    PurgeExportedArchivesOnly : False
    BlockOnArchiveFailure     : False
    KeepArchivingDataForDays  : 14
    PurgeHourOfDay            : 2
    ArchiveDuplicateMessages  : True
    CachePurgingInterval      : 24
    EnableExchangeArchiving   : False

    What makes me suspicious, is the fact that we use a different Client Policy but Global. But if I run "Get-CsSite" I get back "Identity: Site:mobileX". I do not actually exactelly know what Identity for get-csarchivingconfiguration means. All I know is that we have an additional Client Policy called Tag:mXClientPolicy. this is the policy we use and where I have set:

    DisableSavingIM: False
    EnableIMAutoArchiving:
    EnableServerConversationHistory: True

    Not sure whether my configuration retrieved by get-csarchivingconfiguration apply to my users and if they are correct.

    Monday, July 04, 2016 1:37 PM
  • guys did i miss something , the question clearly states when this functionality will be available for on prem deployments. so it looks like its something that is currently available only for 0365 users. Has anyone got the offline messaging working in an on prem deployment please ?
    Saturday, August 27, 2016 5:59 PM
  • Depending on which function you ask. With the actual Skype for Business Client it is available and works on my client.

    regards Holger Technical Specialist UC

    Saturday, August 27, 2016 6:21 PM
  • Good morning,

    unfortunately we encounter the same problem within our SfB deployment.
    I have tried different solutions mentioned in this article and in the internet but it still do not work for our users.

    Our deployment looks like this:

    SfB 2015 CU3 (on-prem) in combination with Exchange 2016 (on-prem).
    My SfB 2016 Client is up to date. (Version 16.0.4417.1000)
    EWS works properly.

    When we try to send an instant message to someone who is offline the user get the response, that the user can not receive IM because the user is unavailable or offline.

    At the moment the ClientPolicy is configured as the following:

    DisableSavingIM -> True
    EnableAutoArchiving -> True
    EnableServerConversationHistory -> False

    Holger you got it to work on your on-prem deployment?

    Any ideas or suggestions for solving this problem?

    Thanks a lot for your help!

    Greets,
    Markus

    Wednesday, August 31, 2016 6:26 AM
  • Hello,

    looks like after I have set DisableSavingIM to True according to this article http://social.technet.microsoft.com/wiki/contents/articles/33839.skype-for-business-leave-messages-offline.aspx it seems to work for me. At least I was able to send a peer-to-peer chat to an offline user who got it as an email.

    Don't realy know if this DisableSavingIM parameter value set tu true instead of false is the key for success, however, it seems to work. We have both, Exchange 2016 and SfB2015 on-premise, SfB is newer version that the min. required. However, my settings now are:

    

    ------------------------------------------------------------------------------------

    Get-CsClientPolicy | select disableSav*,enableIM*,EnableServerCon* | fl *

    DisableSavingIM                 : True
    EnableIMAutoArchiving           :
    EnableServerConversationHistory : True

    ------------------------------------------------------------------------------------

    Also, the chat window of my client, with an offline user, now tells me that this user is offline, but it will recive the caht as missed message....

    If you look several posts above, I have posted a screenshot how it looked before, now it looks like this:

    Dieter


    Monday, September 12, 2016 3:47 PM
  • Hi Dieter,

    thank you for your response.

    I tried to configure it as you but it still won´t work.
    I will try to figure out what the problem is but currently I don´t have any plan what the reason for the issue could be.

    Greets and a nice weekend,
    Markus

    Friday, September 16, 2016 2:24 PM
  • markus_95, did you ever get this working? Are environment is close to yours except we have Exchange 2013 and a similar Skype for business client version of 16.0.4456.1003. I have all the S4B requirements and EnableOfflineIM enabled but we are still not seeing offline messaging work.
    Friday, December 30, 2016 3:37 PM
  • Hello,

    donb't know if this is something new to you, but it is very important to also have a min. version of Skype for Business clients running. Don't know exactely which version is least required. But if not both clients run at lteast that version, offline message between them will not work (or it is enough that the sender has the correct minimum version, don't recall exactely anymore, but definitelly if client is not new enough, offline message will still not work, no matter of correct settings server-side). I use now 16.0.7329.1032, but it worked with some earlier 16.x versions already.

    But we, in our company, also have mixed client version running, and because of that (same server, same policy, but different client versions) offline messages does not work for all of us. I don't even remember whether a new client user recognizes that his peers is not capable of offline messages... it's still a rather shitty apporach, like chat capability of skype for business in general is, that's my opinion. There are lots of good features, while chatting is not one of them.

    Dieter

    Tuesday, January 03, 2017 6:50 AM
  • Hello,

    sry. for the delay of my response.
    @jbales3795
    Unfortunately I did not get it to work until now.
    To be honest I did not spent any additional time in the problem.
    I will wait till an external partner will visit us and try to have a look at it with them.
    I dont even know how to debug it the feature.

    We have the newest CU and the latest Client patches applied but it never worked for anyone in our company.
    There was a specific client version required for this feature but up to now nearly every client should be higher than the required version.

    I dont know if both clients need to be at the required version. I think that the senders SfB Client leverage EWS to send the notification to the users mailbox.

    When I get it to work here, I will tell you!

    Greets,

    Markus

    Tuesday, January 17, 2017 3:47 PM