locked
ProClarity Web Professional 6.1 AS2005 attach msolap.asp RRS feed

  • Question

  • Hello folks,

     

    we have a strange problem. since a month some connections from our users end with ServiceStatus 401 in the log file and the target is this /as/msmdpump.dll/msolap.asp . Other connections are ok, ServiceStatus is 200 and target /as/msmdpump.dll .

     

    I double checked the driver in ProClarity Professional. It shows "Microsoft OLE DB Provider for Analysis Services 9.0".  I have read these instructions ( http://technet.microsoft.com/de-de/library/cc917711(en-us).aspx) many times , but it worked over a year without problems. Some users have reported after a new installation is running again, but not always and not reliable. What can i do to avoid this strange behaviour?

     

    Web Server:

    - Windows Server 2003 Web Edition

    - IIS 6

    - windows authentication with client certificates

    - virtual directory "as" is basic authentication

    - all patches installed

     

    DB Server

    - Windows Server 2003 x64 Standard Edition

    - SQL Server 2008 SP1 x64 Enterprise Edition

    - all patches installed

     

    Client

    - Windows XP SP3 x32

    - ProClarity Web Professional 6.1 with OLE DB Provider 9.0 (as standard driver)

    - all patches installed

     

    Thanks in advance.

     

    Best regards,

    Andreas

    Tuesday, May 4, 2010 7:41 AM

All replies

  • Hi Andreas.  An HTTP 401 response from IIS would indicate either a challenge for credentials was sent or invalid credentials were being passed to IIS.  Every access attempt to IIS will result in a 401 (challenge for credentials) followed by another authentication attempt by the client.  If the 2nd attempt uses invalid credentials, or valid credentials but no access to the content, another 401 challenge would be sent back.  You will want to make sure that any users having access trouble have NTFS rights to the AS virtual directory in IIS and that they can successfully authenticate to it.


    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, May 12, 2010 10:20 PM
  • Hello Sean,

     

    thanks for your answer. Yes, I know this behavior. But I can not understand why it works for me (in corporate environment) and not by customers. I use the same path over the Internet with the client certificate of the customer and it works. The odd, number of customers showed the problem simultaneously. Can it be due to some Windows update?

    I've checked the virtual directory
    again and file system permissions still the same.  It worked for over a year without any problems and we have not changed the configuration or anything. Also the permissions in IIS, everything looks fine. I have the suspicion that the OLE DB driver creates a fallback to 8.0 (SQL 2000) driver, and therefore comes the bad call. Can it be? As I understand it? In ProClarity the OLAP provider  "Microsoft OLE DB Provider for Analysis Services 9.0" is set. In the registry under HKEY_CLASSES_ROOT \ MSOLAP \ CurVer also MSOLAP.3 is set. I do not know if it might have to do with it what?

    Also, I've tried to recreate problem and came across the following thread: http://social.msdn.microsoft.com/forums/en-US/sqlanalysisservices/thread/4fec7701-2289-4248-9fc7-c94ad3c4be6b . In a virtual machine I have attached a ProClarity client.
    Then I deleted the root certificate of the list of trusted root certificate authorities, and could reproduce the same error with the incorrect call via msolap.asp. But the customers seem to have a different problem.


    I do not really further how I could solve the problem.

    Monday, May 17, 2010 5:54 AM