locked
Method 'Post' of object 'IOWSPosData' failed on 'Import Spreadsheet' RRS feed

  • Question

  • This is crazy ...  We have SharePoint 2007 Enterprise in Prod and Stage.  In November 2010 the function of importing a spreadsheet worked in our Prod environment for everyone.  Now it does not we receive the above error (no one can import).  Now in our Staging environment some people can import and some can not ... what the heck.  So, our environment is not like all the statements I have found on the www because it's not the Excel application (example... I can do the import from me laptop in Stage, but I can not do it in production).

    What I need to know is there a setting that needs be set somewhere on the server side?  And, is it also a setting for the user?  (Example.... I am an owner of my own site in Stage and I can do the import, but another site owner can on thier site can not do an import.)

    • Moved by Mike Walsh FIN Thursday, March 17, 2011 6:37 PM admin not general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, March 17, 2011 6:36 PM

Answers

  • Hi,

     

    According to your description, you have got following error:
    Method ‘Post’ of object ‘IOWSPostdata’ Failed.
    Excel queries SharePoint to determine the version. What’s most likely happening is that SharePoint queries the root site such as http://sharepoint, which might not contain a SharePoint site or, more likely, your user does not have the rights to query this hidden SharePoint service. There are many other reasons why this might fail but the long and short of it is that you need to change Excel’s call to check SharePoint’s version.
    In my opinion, you need to make some changes in the EXPTOOWS.XLA. please perform these steps:
    1.        Go to “C:\Program Files\Microsoft Office\Office12\1033”.
    2.        Find “EXPTOOWS.XLA” and double click on it.
    3.        Press “Alt+F11” to display VB code editor.
    4.        Select code window and find “lVer = Application.SharePointVersion(URL)”.
    5.        Add following line “lVer = 2”.
    6.        Save and close the window.
    7.        Restart and see if it worked.
    8.        If not, change “lVer = 3”.
    9.        Restart and see if it worked.
    Please have a try.
     
    Best Regards
    David Hu

     

    • Marked as answer by Emir Liu Monday, March 28, 2011 1:21 AM
    Monday, March 21, 2011 1:39 AM