locked
4.7.0 Timout waiting for client input with big emails on some domains. RRS feed

  • Question

  • Hi,

    We are running exchange 2007 sp1 with a hub and a edge server .
    We are experiencing problems receiving email from specific domains, though not all emails ...looks like it s only emails with big attachements.

    Users from the concerned domain receive NDR with 4.7.0 Timout waiting for client input.

    Here are the smtp receive logs on th edge :

    2009-12-21T06:25:40.520Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,1,192.168.251.51:25,192.168.251.254:53336,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2009-12-21T06:25:40.520Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,2,192.168.251.51:25,192.168.251.254:53336,>,"220 XXXXXX.mail.com Microsoft ESMTP MAIL Service ready at Mon, 21 Dec 2009 07:25:39 +0100",
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,3,192.168.251.51:25,192.168.251.254:53336,<,EHLO mail.mail.com,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,4,192.168.251.51:25,192.168.251.254:53336,>,250-XXXXXX.mail.com Hello [192.168.251.254],
    2009-12-21T06:25:40.567Z,XXXXXXDefault internal receive connector XXXXX,08CC4EEE56C02D62,5,192.168.251.51:25,192.168.251.254:53336,>,250-SIZE 5144576,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,6,192.168.251.51:25,192.168.251.254:53336,>,250-PIPELINING,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,7,192.168.251.51:25,192.168.251.254:53336,>,250-DSN,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,8,192.168.251.51:25,192.168.251.254:53336,>,250-ENHANCEDSTATUSCODES,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,9,192.168.251.51:25,192.168.251.254:53336,>,250-STARTTLS,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,10,192.168.251.51:25,192.168.251.254:53336,>,250-X-ANONYMOUSTLS,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,11,192.168.251.51:25,192.168.251.254:53336,>,250-AUTH,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,12,192.168.251.51:25,192.168.251.254:53336,>,250-X-EXPS NTLM,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,13,192.168.251.51:25,192.168.251.254:53336,>,250-8BITMIME,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,14,192.168.251.51:25,192.168.251.254:53336,>,250-BINARYMIME,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,15,192.168.251.51:25,192.168.251.254:53336,>,250-CHUNKING,
    2009-12-21T06:25:40.567Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,16,192.168.251.51:25,192.168.251.254:53336,>,250 XEXCH50,
    2009-12-21T06:25:40.598Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,17,192.168.251.51:25,192.168.251.254:53336,<,MAIL FROM:<sender@mail.com> SIZE=27667,
    2009-12-21T06:25:40.598Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,18,192.168.251.51:25,192.168.251.254:53336,*,08CC4EEE56C02D62;2009-12-21T06:25:40.520Z;1,receiving message
    2009-12-21T06:25:40.598Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,19,192.168.251.51:25,192.168.251.254:53336,>,250 2.1.0 Sender OK,
    2009-12-21T06:25:40.645Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,20,192.168.251.51:25,192.168.251.254:53336,<,RCPT TO:<recept@mail.fr>,
    2009-12-21T06:25:40.645Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,21,192.168.251.51:25,192.168.251.254:53336,>,250 2.1.5 Recipient OK,
    2009-12-21T06:25:40.676Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,22,192.168.251.51:25,192.168.251.254:53336,<,DATA,
    2009-12-21T06:25:40.676Z,XXXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,23,192.168.251.51:25,192.168.251.254:53336,>,354 Start mail input; end with <CRLF>.<CRLF>,

    2009-12-21T06:34:46.926Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,24,192.168.251.51:25,192.168.251.254:53336,>,451 4.7.0 Timeout waiting for client input,
    2009-12-21T06:34:46.926Z,XXXXXX\Default internal receive connector XXXXXX,08CC4EEE56C02D62,25,192.168.251.51:25,192.168.251.254:53336,-,,Local

    I have already tried to set the timeout for the internal receive connector to 15 minutes, doesn t change anything.

    Anyone can help please ?

    Thanks !



    Monday, December 21, 2009 10:43 AM

All replies

  • Likely the problem is with the sending servers, or the network link between the two sites.

    1. Try testing for MTU problems between you and them. They may have to do this from their end.
    http://support.microsoft.com/default.aspx/kb/159211

    MTU problems or firewall rules can cause large IP packets to be silently dropped by intermediate routers, and this can cause this problem.


    2. Find out what type of server the sending server is. Usually "telnet ip.ad.dr.ess 25" will give you a banner telling you the mail server software in use. The message should end with a dot on a line on its own. If it is not correctly formatted this may be lost - (seen with exchange servers sending under some circumstances).
    Monday, December 21, 2009 1:48 PM
  • Hi,

    Whether the Spam filter server or firewall deployed in your environment?

    If there is, please make the configuration or disable it to test this issue.

    Thanks

    Allen
    Wednesday, December 23, 2009 7:30 AM
  • Thanks a lot for your answers.

    @Benhaha

    I ll investigate the blackhole issue but i m on Windows 2008. Isn t the blackhole detection already enabled on it ?

    Here is my banner:

    220 server.mycompany.com Microsoft ESMTP MAIL Service ready at Wed, 23 D
    ec 2009 10:57:16 +0100

    And here is the remote server causing problem ' s banner :

    220 SMTP Server ready Service ready

    The logs show there s no dot at the end of the smtp transaction with the remote domains causing problems.
    But i have no idea how to correct this.

    @Allen Song

    I have Forefront 2010 installed on the hub server, our edge server is on a dmz.

    I ll try to disable it.


    Thanks again !!

    Wednesday, December 23, 2009 10:10 AM
  • Hi,

    The other cause of this error is messages which are malformed on the queue. I have seen this with transport events which modify the message, (such as adding disclaimers) if they do not ensure the final message has a trailing CRLF. However this usually happens with plain-text only messages which are usually small - you said it happens with large messages.

    I speculate you may also get this with messages submitted via the pickup directory if they don't have a trailing CRLF. In that case it maybe that setting SmtpDotStuffPickupDirFiles to 1 helps.

    Cheers,
    Ben

    • Proposed as answer by Benhaha Wednesday, January 13, 2010 11:57 AM
    Wednesday, January 13, 2010 11:57 AM