none
Provision exchange 2013 groups through FIM RRS feed

  • Question

  • I am using active directory management agent to provision mail enabled security groups in Exchange 2013.

    I have selected Provisioning for Exchange 2010 (as suggested on other websites) because we do not have option for exchange 2013. And then in the box => http://{Server-Name}/Powershell

    Everything works fine but the group is created as Exchange 2007(our previous version) rather than Exchange 2013. Can anyone help  me on this please.


    Monday, March 2, 2015 2:32 PM

Answers

  • Hello,

    I also have a similar issue with contacts some time ago.

    Settting msExchVersion on inital attribute flow worked for me until today with no issues.

    Dont forget to maybe adjust the value on next Exchange Version (and maybe SP's ?).

    -Peter


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    • Marked as answer by Shobhitvaish Wednesday, March 4, 2015 9:14 AM
    Wednesday, March 4, 2015 8:42 AM

All replies

  • What attribute(s) do you see on the group that indicate it is "created as Exchange 2007"?

    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    Tuesday, March 3, 2015 2:39 PM
  • Group shows up in Exchange 2007 management console rather than exchange 2013 console.  Our Exchange team also have confirmed the same.

    FYI, I am exporting value for :- groupType,mailnickname, samaccountname, member and manager. This is bit urgent. Can you please help.

    Tuesday, March 3, 2015 2:51 PM
  • I would start with the latest FIM hotfix http://support.microsoft.com/kb/3022704/en-us which has the following comment:

    Synchronization Service

    Issue 1
    When the Active Directory global address list (GALSync) management agent is used against an Active Directory forest that hosts Exchange Server 2013, the GALSync solution does not generate the correct value for the msExchVersion attribute.

    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    Tuesday, March 3, 2015 3:05 PM
  • Thanks David for your reply. This is very helpful, I would give it a try tomorrow. FYI, I am using active directory MA to provision groups(not gal sync). So can you please let me know whether this hot fix will take care of of AD MA as well?

    Tuesday, March 3, 2015 4:10 PM
  • Shobhitvaish,

    I think its more likely that the fix above is specific to the GALSYNC solution provided out of the box with FIM. If you are using the AD MA to provision group mailboxes, I think your problem is more likely that you have a mixed Exchange environment with both Exchange 2007 and 2010 servers and the homeMDB and msExchHomeServerName(if you are setting this, which is required for E2k10) values are for an Exchange 2007 server.

    Make sure that both of these point to an Exchange 2010 CAS machine and I would expect that the msExchVersion should be set appropriately by Exchange.

    Wednesday, March 4, 2015 5:05 AM
  • Just now I tried to manually set msExchVersion through FIM during export and the group got created as Exchange 2013. Can I go ahead with this approach or it will cause any issue?
    Wednesday, March 4, 2015 5:23 AM
  • Hello,

    I also have a similar issue with contacts some time ago.

    Settting msExchVersion on inital attribute flow worked for me until today with no issues.

    Dont forget to maybe adjust the value on next Exchange Version (and maybe SP's ?).

    -Peter


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    • Marked as answer by Shobhitvaish Wednesday, March 4, 2015 9:14 AM
    Wednesday, March 4, 2015 8:42 AM
  • Thanks Peter for your reply. I'll go ahead with this approach then.
    Wednesday, March 4, 2015 9:14 AM
  • That is the exact problem the hotfix addresses

    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    Monday, March 9, 2015 2:50 PM