locked
Public folder permisions isinherited RRS feed

  • Question

  • I have run the command

    Add-PublicFolderAdministrativePermission -Identity "\Marketing" -User "Chris" -AccessRights AllExtendedRights -Inheritance SelfAndChildren

    out put of the command

      

    Identity             User        AccessRights                    IsInherited   Deny

    --------             ----                 ------------        ----------- ----

    \Markiting    LT\Chris        {AllExtendedRights}             False       False

     

    But question is that i want to make isinherited as true  Please advice.


    • Edited by RSMR Wednesday, October 12, 2011 11:13 AM
    Wednesday, October 12, 2011 10:58 AM

Answers

  • What it is showing is that the user Chris has the permission on Markiting folder but this permission is NOT inherited from parent and it is explicitly set on this folder.

    So if you want this folder to inherit the permission from the parent the parameter should be -Inheretencetype All


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security | MCP
    • Proposed as answer by Jason LJS Friday, October 14, 2011 1:35 AM
    • Marked as answer by Jason LJS Wednesday, October 19, 2011 1:05 AM
    Wednesday, October 12, 2011 5:44 PM

All replies

  • That would only be true if the permission listed *was* inherited from a parent object.

     

    Wednesday, October 12, 2011 11:40 AM
  • So do you me to say that it will be

    Add-PublicFolderAdministrativePermission -Identity "\Marketing" -User "Chris" -AccessRights AllExtendedRights -Inheritance Parent 

    Wednesday, October 12, 2011 2:34 PM
  • If you mean you want to set that then use -InheritanceType - http://technet.microsoft.com/en-us/library/aa997986.aspx
    Sukh
    Wednesday, October 12, 2011 4:28 PM
  • What it is showing is that the user Chris has the permission on Markiting folder but this permission is NOT inherited from parent and it is explicitly set on this folder.

    So if you want this folder to inherit the permission from the parent the parameter should be -Inheretencetype All


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security | MCP
    • Proposed as answer by Jason LJS Friday, October 14, 2011 1:35 AM
    • Marked as answer by Jason LJS Wednesday, October 19, 2011 1:05 AM
    Wednesday, October 12, 2011 5:44 PM