locked
Field shading not working consistently even when set to "Always" RRS feed

  • Question

  • I'm writing a word Doc and inserting fields for things like "Date", "Page number", "Captions" and "in-text cross references", as well as citations using Endnote. I want ALL fields to show up with the grey shading so I can see where they are ( i.e. so they don't just look like regular text). 

    When I turn on File-> Options->Field Shading to show Always it's not working...  <g class="gr_ gr_596 gr-alert gr_gramm gr_disable_anim_appear Punctuation only-ins replaceWithoutSep" data-gr-id="596" id="596">Well</g> it seems to work for some fields such as Caption number and Cross references captions, and for the reference list at the end of the document (created by Endnote) but is NOT working for Date Field, Page number Field, or (most importnantly) in-text endnote citations. 

    Interestingly if I type a field in using either Ctr+F9 for Date or Page, rather than using insert menu or use curly brackets for Endnote citations {} sometimes I could get the field to show but not consistently. I Have a screenshot of some examples of the field shading I can send if more explanation is necessary.

    Can anyone explain if this is an actual problem or if there are different field types and I'm not understanding the difference? I know older versions of Word such as 2003 and 2007 I had no problems showing field shading for all fields.

    Friday, November 18, 2016 4:11 AM

All replies

  • Have you tried repairing the Office installation (via Windows Control Panel > Programs > Programs & Features > Microsoft Office (version) > Change > Repair)?

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Friday, November 18, 2016 5:05 AM
  • I have tried that yes, it didn't work unfortunately. 

    Friday, November 18, 2016 8:41 AM
  • If it's only affect one document (or just a few), it's possible the document has acquired some of corruption. Corrupt documents can often be 'repaired' by inserting a new, empty, paragraph at the very end, copying everything except that new paragraph to a new document based on the same template (headers & footers may need to be copied separately), closing the old document and saving the new one over it.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Friday, November 18, 2016 10:01 AM
  • Right. So... not sure if I just accidentally fixed it or not but I’m not going to jinx it by digging too much deeper.

    Based on some suggestions on another thread, I went looking in the Registry Editor. Windows key + R to open Run, type regedit and then click OK.

    Navigate to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Word\Options

    I right clicked on the ShadeFields key and clicked Modify but then just clicked Ok and closed the window. The value at the end should be (0) for Never shade, (1) for Always shade and (2) for When selected.

    When I opened Word again and tried out all my field options they now all show shading as expected. 


    Friday, November 18, 2016 10:09 AM